summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2020-04-05 07:43:40 +0300
committersurefire2020-04-05 07:43:40 +0300
commitb2e4eb95fd4d12e1e31be037fe867ec89ad2aec8 (patch)
treef1bf86c814125e4554e607a803553b33a4108514
parent01b36e68b32702e930d227b5c4157370e56f095d (diff)
downloadaur-b2e4eb95fd4d12e1e31be037fe867ec89ad2aec8.tar.gz
upgpkg: keeweb 1.13.1
Signed-off-by: surefire <surefire@cryptomile.net>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
-rw-r--r--package.json.patch.js11
3 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69a1e0ce63fc..7f7ef116fbb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = keeweb
pkgdesc = Desktop password manager compatible with KeePass databases
- pkgver = 1.13.0
+ pkgver = 1.13.1
pkgrel = 1
url = https://keeweb.info
arch = any
@@ -14,12 +14,12 @@ pkgbase = keeweb
depends = electron
optdepends = xdotool: for auto-type
conflicts = keeweb-desktop
- source = keeweb::git+https://github.com/keeweb/keeweb.git#tag=v1.13.0
+ source = keeweb::git+https://github.com/keeweb/keeweb.git#tag=v1.13.1
source = keeweb.sh
source = package.json.patch.js
sha1sums = SKIP
sha1sums = c925527f25e732d58438ee16b1c93b33be7bf9c4
- sha1sums = 19c9db9079a08e82b5418609596201b358ac815d
+ sha1sums = d64a29202b71f30b1c4eaef5c01cee574b55894a
pkgname = keeweb
diff --git a/PKGBUILD b/PKGBUILD
index cf0e6203fb5d..5f9994330244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: surefire@cryptomile.net
pkgname=keeweb
-pkgver=1.13.0
+pkgver=1.13.1
pkgrel=1
pkgdesc="Desktop password manager compatible with KeePass databases"
arch=('any')
@@ -26,7 +26,7 @@ source=(
sha1sums=('SKIP'
'c925527f25e732d58438ee16b1c93b33be7bf9c4'
- '19c9db9079a08e82b5418609596201b358ac815d')
+ 'd64a29202b71f30b1c4eaef5c01cee574b55894a')
prepare() {
cd "${pkgname}"
@@ -35,22 +35,17 @@ prepare() {
node ../package.json.patch.js
sed -i \
- -e "/const electronVersion/ s/pkg.dependencies.electron/'$(</usr/lib/electron/version)'/" \
- -e "/codeSignConfig.windows/ d" \
+ -e "/const electronVersion/ s/pkg.dependencies.electron/'$(</usr/lib/electron/version)'/" \
Gruntfile.js
sed -i \
- -e "/'eslint',/ d" \
- -e "/'uglify',/ d" \
+ -e "/'eslint',/ d" \
grunt.tasks.js
sed -i \
- -e '/Exec=/ c \Exec=keeweb %u' \
- package/deb/usr/share/applications/keeweb.desktop
-
- sed -i \
- -e 's/: "[^@]*@github:/: "github:/' \
- package-lock.json
+ -e "/const BundleAnalyzerPlugin/ d" \
+ -e "/new BundleAnalyzerPlugin({$/, /^\s*})$/ d" \
+ build/webpack.config.js
}
build() {
@@ -66,7 +61,7 @@ build() {
npm install
npm install css-loader
- npx grunt --no-sign build-web-app build-desktop-app-content
+ npx grunt build-web-app build-desktop-app-content
asar p tmp/desktop/app tmp/app.asar
}
diff --git a/package.json.patch.js b/package.json.patch.js
index 46b5460a1cab..8d3a7ac41cf1 100644
--- a/package.json.patch.js
+++ b/package.json.patch.js
@@ -7,19 +7,22 @@ const data = JSON.parse(fs.readFileSync(PATCHABLE_FILE));
// remove extra dependencies
const removePkg = [
+ /^chai$/,
+ /^electron-/,
/^electron$/,
- /^eslint/,
- /^grunt-concurrent$/,
+ /^eslint-/,
+ /^eslint$/,
/^grunt-contrib-compress$/,
/^grunt-contrib-deb$/,
- /^grunt-contrib-uglify$/,
/^grunt-contrib-watch$/,
/^grunt-electron$/,
/^grunt-eslint$/,
+ /^mocha$/,
/^puppeteer$/,
/^stats-webpack-plugin$/,
/^sumchecker$/,
- /^webpack-dev-server/,
+ /^webpack-bundle-analyzer$/,
+ /^webpack-dev-server$/,
];
Object.keys(data.dependencies).forEach(dep => {