summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2016-02-26 09:16:56 +0800
committerwenLiangcan2016-02-26 09:16:56 +0800
commitca9a3bf554d507ae5afdd1e3f4fc21818ccf918c (patch)
treec7b9f3490bbd16db42be78d2d77c0237a416f61f
downloadaur-ca9a3bf554d507ae5afdd1e3f4fc21818ccf918c.tar.gz
keeweb-git 1.0.4.0.ga6e7afe-1.
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD59
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3362db2d07eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Feb 26 01:16:33 UTC 2016
+pkgbase = keeweb-git
+ pkgdesc = Desktop password manager compatible with KeePass databases.
+ pkgver = 1.0.4.0.ga6e7afe
+ pkgrel = 1
+ url = https://github.com/antelle/keeweb
+ arch = any
+ license = MIT
+ makedepends = nodejs-grunt
+ makedepends = npm
+ depends = electron
+ depends = xdg-utils
+ depends = sh
+ provides = keeweb
+ provides = keeweb-desktop
+ conflicts = keeweb
+ source = git+https://github.com/antelle/keeweb.git
+ sha1sums = SKIP
+
+pkgname = keeweb-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..69e800010b61
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+### https://raw.github.com/github/gitignore/fa441f903154d8159ef71db23d4816d802450fef/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+keeweb/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b1e274c26cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+pkgname=keeweb-git
+_pkgname=keeweb
+pkgver=1.0.4.0.ga6e7afe
+pkgrel=1
+pkgdesc="Desktop password manager compatible with KeePass databases."
+arch=('any')
+url="https://github.com/antelle/keeweb"
+license=('MIT')
+depends=('electron' 'xdg-utils' 'sh')
+makedepends=('nodejs-grunt' 'npm')
+provides=("${_pkgname}" "${_pkgname}-desktop")
+conflicts=("${_pkgname}")
+source=('git+https://github.com/antelle/keeweb.git')
+sha1sums=('SKIP')
+_desktop="${_pkgname}.desktop"
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags --long | sed 's/^v//;s/-/./g'
+}
+
+prepare() {
+ cat > ${_desktop} << EOF
+[Desktop Entry]
+Type=Application
+Name=Keeweb
+Comment=KeePass web app
+Exec=/usr/bin/${_pkgname}
+Icon=/usr/share/${_pkgname}/electron/icon.png
+Categories=Utility;
+Terminal=false
+StartupNotify=true
+Version=${pkgver}
+EOF
+
+ cat > "${_pkgname}.sh" << EOF
+#!/usr/bin/env sh
+electron /usr/share/${_pkgname}/electron --htmlpath=/usr/share/${_pkgname}/html \$*
+EOF
+}
+
+build() {
+ cd ${_pkgname}
+ npm install
+ grunt
+}
+
+package() {
+ cd "${_pkgname}"
+ find ./{electron,tmp} -type f -exec install -Dm644 {} \
+ "${pkgdir}/usr/share/${_pkgname}/{}" \;
+ mv "${pkgdir}/usr/share/${_pkgname}/"{tmp,html}
+ install -Dm644 MIT-LICENSE.txt "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${_desktop}" "${pkgdir}/usr/share/applications/${_desktop}"
+ install -Dm755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+}
+