summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2022-01-29 00:33:14 +0100
committerAlphaJack2022-01-29 00:33:14 +0100
commitf61702a3e288db1feaf3676a4d6562347f19337c (patch)
tree4cb3318c61d20e419048e9bb26099f2ab7ace841
downloadaur-f61702a3e288db1feaf3676a4d6562347f19337c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36cfb943b87b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = keeweb-web
+ pkgdesc = Free cross-platform password manager compatible with KeePass
+ pkgver = 1.18.7
+ pkgrel = 1
+ url = https://keeweb.info/
+ arch = any
+ license = MIT
+ makedepends = unzip
+ conflicts = keeweb-html
+ replaces = keeweb-html
+ noextract = keeweb-web-1.18.7.zip
+ options = !strip
+ source = keeweb-web-1.18.7.zip::https://github.com/keeweb/keeweb/releases/download/v1.18.7/KeeWeb-1.18.7.html.zip
+ sha256sums = 6f3d06891117072e62b43b08a84bdaf4fc43c0aae6127ac6c2e7564299d8a890
+
+pkgname = keeweb-web
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64f77ca614c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="keeweb-web"
+pkgver=1.18.7
+pkgrel=1
+pkgdesc="Free cross-platform password manager compatible with KeePass"
+url="https://keeweb.info/"
+license=("MIT")
+arch=("any")
+conflicts=("keeweb-html")
+replaces=("keeweb-html")
+makedepends=("unzip")
+source=("$pkgname-$pkgver.zip::https://github.com/keeweb/keeweb/releases/download/v$pkgver/KeeWeb-$pkgver.html.zip")
+noextract=("$pkgname-$pkgver.zip")
+sha256sums=('6f3d06891117072e62b43b08a84bdaf4fc43c0aae6127ac6c2e7564299d8a890')
+options=("!strip")
+
+package(){
+ install -d "$pkgdir/usr/share/webapps"
+ unzip -q -o "$pkgname-$pkgver.zip" -d "$pkgdir/usr/share/webapps/keeweb"
+}
+