summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-01 23:22:17 +0000
committerJoão Figueiredo2021-02-01 23:22:17 +0000
commitd6c18326bf48173c0dc6cb5308f98b54f3a587e5 (patch)
tree516b06415f508343d72d403e00ad28486c6a778b
parentea96381929b038f546e07522b595543657dc318e (diff)
downloadaur-d6c18326bf48173c0dc6cb5308f98b54f3a587e5.tar.gz
Merged with official ABS kemoticons PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 32 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68538ccd4630..4b4855d3f7e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = kemoticons-git
- pkgdesc = KEmoticons
- pkgver = r325.5379921
+ pkgdesc = Support for emoticons and emoticons themes
+ pkgver = 5.79.0_r354.gb4e0573
pkgrel = 1
- url = https://projects.kde.org/projects/frameworks/kemoticons
- arch = i686
+ url = https://community.kde.org/Frameworks
arch = x86_64
- groups = kf5
+ groups = kf5-git
license = LGPL
- makedepends = extra-cmake-modules-git
makedepends = git
+ makedepends = extra-cmake-modules-git
+ makedepends = doxygen
+ makedepends = qt5-tools
+ makedepends = qt5-doc
+ depends = karchive-git
depends = kservice-git
provides = kemoticons
conflicts = kemoticons
source = git+https://github.com/KDE/kemoticons.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = kemoticons-git
diff --git a/PKGBUILD b/PKGBUILD
index 76ed142d9184..c2cd999abb37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,35 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
+# Merged with official ABS kemoticons PKGBUILD by João, 2021/02/01 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=kemoticons-git
-pkgver=r325.5379921
+pkgver=5.79.0_r354.gb4e0573
pkgrel=1
-pkgdesc='KEmoticons'
-arch=('i686' 'x86_64')
-url='https://projects.kde.org/projects/frameworks/kemoticons'
-license=('LGPL')
-depends=('kservice-git')
-makedepends=('extra-cmake-modules-git' 'git')
-groups=('kf5')
-conflicts=(kemoticons)
-provides=(kemoticons)
-source=('git+https://github.com/KDE/kemoticons.git')
-md5sums=('SKIP')
+pkgdesc='Support for emoticons and emoticons themes'
+arch=($CARCH)
+url='https://community.kde.org/Frameworks'
+license=(LGPL)
+depends=(karchive-git kservice-git)
+makedepends=(git extra-cmake-modules-git doxygen qt5-tools qt5-doc)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(kf5-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
- cd kemoticons
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- mkdir -p build
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 "set(KF5\?_VERSION" CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd build
- cmake ../kemoticons \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
- -DBUILD_TESTING=OFF
- make
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_QCH=ON
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}