summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelmur2015-06-12 16:33:55 +0200
committerfelmur2015-06-12 16:33:55 +0200
commita56f2b5c10c608b9246dc8ddf393dc5d1dd22567 (patch)
treefa5251473eab715da5147420a10b1ee33493d511
downloadaur-a56f2b5c10c608b9246dc8ddf393dc5d1dd22567.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
-rw-r--r--kencfs-1.5.0.tar.gzbin0 -> 156217 bytes
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cd6a828536b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kencfs
+ pkgdesc = GUI frontend for encfs. Create, mount, umount and delete your encrypted fs.
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://kde-apps.org/content/show.php/KEncFS?content=134003
+ arch = i686
+ arch = x86_64
+ license = (L)GPL
+ depends = encfs>=1.7.4-8
+ depends = fuse>=2.9.2-1
+ depends = kdelibs
+ source = kencfs-1.5.0.tar.gz
+ md5sums = cbcde8d0eb3eb351a6de5f7e706ae424
+
+pkgname = kencfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..659eded9e9f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+#Maintainer: Felice Murolo <linuxboy@fel.hopto.org>
+pkgname=kencfs
+pkgver=1.5.0
+pkgrel=1
+#epoch=
+pkgdesc="GUI frontend for encfs. Create, mount, umount and delete your encrypted fs."
+arch=('i686' 'x86_64')
+url="http://kde-apps.org/content/show.php/KEncFS?content=134003"
+license=('(L)GPL')
+#groups=()
+depends=('encfs>=1.7.4-8' 'fuse>=2.9.2-1' 'kdelibs')
+#makedepends=()
+#checkdepends=()
+#optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+#options=()
+#install=
+#changelog=
+source=($pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=('cbcde8d0eb3eb351a6de5f7e706ae424') #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake-qt4
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ #make DESTDIR="$pkgdir/" install
+ make INSTALL_ROOT=$pkgdir install || return 1
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/kencfs-1.5.0.tar.gz b/kencfs-1.5.0.tar.gz
new file mode 100644
index 000000000000..9e00e22bb258
--- /dev/null
+++ b/kencfs-1.5.0.tar.gz
Binary files differ