summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2016-01-03 12:28:38 +0100
committerAntonio Rojas2016-01-03 12:28:38 +0100
commitf45415619bcee506860564c2822ae51ff3c69974 (patch)
tree6e629b2b8c8f041fc1e9c3b737e1930aaf570221
parentd02d097098d62208c4162cff7d2a2fa3bd486bd6 (diff)
downloadaur-f45415619bcee506860564c2822ae51ff3c69974.tar.gz
Update to 0.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--stripPicture20
3 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a78e7e67ddc9..dcd7fda4db60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Dec 21 22:41:00 UTC 2015
+# Sun Jan 3 11:28:31 UTC 2016
pkgbase = keneric
pkgdesc = A generic thumbnailer for KDE
- pkgver = 0.2
+ pkgver = 0.3
pkgrel = 1
url = http://kde-apps.org/content/show.php/?content=174485
arch = i686
@@ -10,12 +10,12 @@ pkgbase = keneric
license = GPL
makedepends = extra-cmake-modules
depends = kio
- source = http://kde-apps.org/CONTENT/content-files/174485-keneric-0.2.tar.gz
+ source = http://kde-apps.org/CONTENT/content-files/174485-keneric-0.3.tar.gz
source = stripPicture
source = kenerickrita.desktop
source = kenericblend.desktop
- md5sums = 96a74b4321816ad5851bcbe7601ed79f
- md5sums = 0380500677769af4abe2826b01793a1d
+ md5sums = 29cc6c23fef1c766c409b35d51628dce
+ md5sums = c9f4461d011bdcaea3807a2ca4d73ed5
md5sums = 52eb5908aa2414c490853312b6f71a81
md5sums = 723f0d5769a5e35019ba5892ce72f265
diff --git a/PKGBUILD b/PKGBUILD
index 28afa19d3c0c..4e4aaf0c21e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antonio Rojas <arojas@archlinux.org>
pkgname=keneric
-pkgver=0.2
+pkgver=0.3
pkgrel=1
pkgdesc='A generic thumbnailer for KDE'
arch=(i686 x86_64)
@@ -10,8 +10,8 @@ license=(GPL)
depends=(kio)
makedepends=(extra-cmake-modules)
source=("http://kde-apps.org/CONTENT/content-files/174485-$pkgname-$pkgver.tar.gz" stripPicture kenerickrita.desktop kenericblend.desktop)
-md5sums=('96a74b4321816ad5851bcbe7601ed79f'
- '0380500677769af4abe2826b01793a1d'
+md5sums=('29cc6c23fef1c766c409b35d51628dce'
+ 'c9f4461d011bdcaea3807a2ca4d73ed5'
'52eb5908aa2414c490853312b6f71a81'
'723f0d5769a5e35019ba5892ce72f265')
diff --git a/stripPicture b/stripPicture
index 2ca1706b78ee..9c0319938dcc 100644
--- a/stripPicture
+++ b/stripPicture
@@ -1,28 +1,24 @@
#!/bin/sh
-# Usage: stripPicture fileaname
+# Usage: stripPicture fullname mime exportPicture
fullname="$1"
-filename=$(basename "$1")
-extension="${filename##*.}"
+mime="$2"
+exportPicture="$3"
-mkdir -p $HOME/.config/keneric
-exportPicture=$HOME/.config/keneric/UseThisPicture.png
+# thumbnail options by mime type
+case "$mime" in
-# thumbnail options by extension type
-case "$extension" in
-
-
- kra|Kra|KRA)
+ application/x-krita)
unzip -p "$fullname" preview.png > "$exportPicture"
exit
;;
- ora|Ora|ORA)
+ image/openraster)
unzip -p "$fullname" Thumbnails/thumbnail.png > "$exportPicture"
exit
;;
- blend|Blend|BLEND)
+ application/x-blender)
blender-thumbnailer.py "$fullname" "$exportPicture"
exit
;;