summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPysen X2023-03-26 19:53:57 +0200
committerPysen X2023-03-26 19:53:57 +0200
commitbe8576971f657b547ebe1e80f38826e1543309df (patch)
tree20bb6b2c2b30e05b89804e4881f7991c87f11b54
parent0ce7b8672130eff0167784d8e03432aaff67374b (diff)
downloadaur-be8576971f657b547ebe1e80f38826e1543309df.tar.gz
Disable the automatic version check before creating completion files
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be2cb1a2f25a..75b0bc0dcdea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = keptn-bin
pkgdesc = The Keptn CLI includes commands to perform various tasks to manage the Keptn installation and projects
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/keptn/keptn
arch = x86_64
arch = armv7l
diff --git a/PKGBUILD b/PKGBUILD
index c29d6cae63bf..549f78d88420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=keptn-bin
pkgdesc="The Keptn CLI includes commands to perform various tasks to manage the Keptn installation and projects"
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'armv7l' 'armv7h' 'aarch64')
url="https://github.com/keptn/keptn"
license=('Apache')
@@ -31,6 +31,8 @@ source+=(${pkgname/-bin/}-${pkgver}-${_pkgarch}::"https://github.com/keptn/keptn
package() {
_output="${srcdir}/${pkgname/-bin/}-${pkgver}-${_pkgarch}"
install -Dm 0755 "${pkgname/-bin/}-${pkgver}-linux-${_pkgarch}" "${pkgdir}/usr/bin/keptn"
+ # Disable daily automatic version check or else the completion output is incorrect
+ ${pkgdir}/usr/bin/keptn set config AutomaticVersionCheck false
# Shell completions
mkdir -p completions
${pkgdir}/usr/bin/keptn completion bash > completions/keptn
@@ -39,6 +41,4 @@ package() {
install -D -m 0644 completions/keptn ${pkgdir}/usr/share/bash-completion/completions/keptn
install -D -m 0644 completions/_keptn ${pkgdir}/usr/share/zsh/site-functions/_keptn
install -D -m 0644 completions/keptn.fish ${pkgdir}/usr/share/fish/vendor_completions.d/keptn.fish
- # Uncomment to disable daily automatic version check (optional)
- # ${pkgdir}/usr/bin/keptn set config AutomaticVersionCheck false
}