summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Lybin2015-10-27 01:01:07 +0700
committerLev Lybin2015-10-27 01:01:07 +0700
commitbdf92417caf46b367cee153df480822599a17bf2 (patch)
tree29774ef2316e99329e85053d6610d52b2c6d8ecc
downloadaur-bdf92417caf46b367cee153df480822599a17bf2.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ce4653af160
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = keratin-git
+ pkgdesc = a fork of clipmenu, a simple clipboard manager using dmenu and xsel/xclip
+ pkgver = 1.0.0.r20.g9f96e94
+ pkgrel = 1
+ url = https://github.com/llybin/keratin
+ arch = any
+ license = ISC
+ depends = dmenu
+ depends = xsel
+ conflicts = clipmenu-git,
+ conflicts = clipmenu
+ source = git+https://github.com/llybin/keratin.git
+ md5sums = SKIP
+
+pkgname = keratin-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6d6a25270f52
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+keratin-git-*.src.tar.gz
+keratin-git-*.pkg.tar.xz
+keratin/
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aa2305c838f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Lev Lybin <aur@devtrue.net>
+
+pkgname=keratin-git
+_gitname=keratin
+pkgver=1.0.0.r20.g9f96e94
+pkgrel=1
+pkgdesc='a fork of clipmenu, a simple clipboard manager using dmenu and xsel/xclip'
+url='https://github.com/llybin/keratin'
+arch=('any')
+license=('ISC')
+depends=(dmenu xsel)
+conflicts=(clipmenu-git, clipmenu)
+
+source=(git+https://github.com/llybin/keratin.git)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long | sed 's/^FOO-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${_gitname}"
+ install -D -m755 keratin "${pkgdir}/usr/bin/keratin"
+ install -D -m755 keratin-d "${pkgdir}/usr/bin/keratin-d"
+}