aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaber-nyan2018-09-09 12:52:36 +0300
committersaber-nyan2018-09-09 12:52:36 +0300
commit5eef5a9787da5fcf978585f94f1d09d300fbcb6f (patch)
tree8d3319fa858ae77eb1fd48f37c805c5b9a04651d
parenta43cd6bca2bbe65440f544e5f08d53b96c870903 (diff)
downloadaur-5eef5a9787da5fcf978585f94f1d09d300fbcb6f.tar.gz
Run ALPM-hooks before everything else
Closes #2
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--10-linux-modules-post.hook (renamed from linux-modules-post.hook)0
-rw-r--r--10-linux-modules-pre.hook (renamed from linux-modules-pre.hook)0
-rw-r--r--PKGBUILD10
5 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d86c0939b943..3d33e6c2cd24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kernel-modules-hook
pkgdesc = Keeps your system fully functional after a kernel upgrade
- pkgver = 0.1.1
+ pkgver = 0.1.2
pkgrel = 1
url = https://github.com/saber-nyan/kernel-modules-hook
install = kernel-modules-hook.install
@@ -9,8 +9,8 @@ pkgbase = kernel-modules-hook
depends = rsync
source = linux-modules-cleanup.conf
source = linux-modules-cleanup.service
- source = linux-modules-post.hook
- source = linux-modules-pre.hook
+ source = 10-linux-modules-post.hook
+ source = 10-linux-modules-pre.hook
sha256sums = 4169b44c297ddb7aad2220c6eba7c7942e3396f92528c59617955ab5560cb4cf
sha256sums = 5d947290ef8c94b33c79c531e5615f4c9bea38e7649092d34af3bf0af5b1ca24
sha256sums = 39a124a4fb5cf3f2cace0bd5bd203a6d5d78aac1eb7dfb7610b91839281ac58b
diff --git a/.gitignore b/.gitignore
index 3d21ac3b741a..06d9789e666f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -15,6 +15,5 @@
kernel-modules-hook.install
linux-modules-cleanup.conf
linux-modules-cleanup.service
-linux-modules-post.hook
-linux-modules-pre.hook
-
+10-linux-modules-post.hook
+10-linux-modules-pre.hook
diff --git a/linux-modules-post.hook b/10-linux-modules-post.hook
index b4d15d1ae8ce..b4d15d1ae8ce 100644
--- a/linux-modules-post.hook
+++ b/10-linux-modules-post.hook
diff --git a/linux-modules-pre.hook b/10-linux-modules-pre.hook
index 257f5f5ac039..257f5f5ac039 100644
--- a/linux-modules-pre.hook
+++ b/10-linux-modules-pre.hook
diff --git a/PKGBUILD b/PKGBUILD
index 4821b4bd6745..3a51b242a48c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: saber-nyan <saber-nyan@ya.ru>
# Hooks: https://www.reddit.com/r/archlinux/comments/4zrsc3/keep_your_system_fully_functional_after_a_kernel/d6yin0r/
pkgname=kernel-modules-hook
-pkgver=0.1.1
+pkgver=0.1.2
pkgrel=1
pkgdesc="Keeps your system fully functional after a kernel upgrade"
arch=('any')
@@ -12,8 +12,8 @@ install="${pkgname}.install"
source=(
"linux-modules-cleanup.conf"
"linux-modules-cleanup.service"
- "linux-modules-post.hook"
- "linux-modules-pre.hook"
+ "10-linux-modules-post.hook"
+ "10-linux-modules-pre.hook"
)
sha256sums=(
"4169b44c297ddb7aad2220c6eba7c7942e3396f92528c59617955ab5560cb4cf"
@@ -25,6 +25,6 @@ sha256sums=(
package() {
install -Dm644 'linux-modules-cleanup.conf' "${pkgdir}/usr/lib/tmpfiles.d/linux-modules-cleanup.conf"
install -Dm644 'linux-modules-cleanup.service' "${pkgdir}/usr/lib/systemd/system/linux-modules-cleanup.service"
- install -Dm644 'linux-modules-post.hook' "${pkgdir}/usr/share/libalpm/hooks/linux-modules-post.hook"
- install -Dm644 'linux-modules-pre.hook' "${pkgdir}/usr/share/libalpm/hooks/linux-modules-pre.hook"
+ install -Dm644 '10-linux-modules-post.hook' "${pkgdir}/usr/share/libalpm/hooks/10-linux-modules-post.hook"
+ install -Dm644 '10-linux-modules-pre.hook' "${pkgdir}/usr/share/libalpm/hooks/10-linux-modules-pre.hook"
}