aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Baz2019-11-11 11:29:07 +0100
committerMaxim Baz2019-11-11 11:29:07 +0100
commitd7983e3e2bb63020f26be59ff13a37dd3b02e355 (patch)
tree6f61ed23662d53ae46b0b89621083fd31ed9ac97
parentd95e1d63a6a16fd6dc6c9d5a5fc65ade9931f269 (diff)
downloadaur-d7983e3e2bb63020f26be59ff13a37dd3b02e355.tar.gz
Adapt to new kernel installation
All official kernels no longer install the actual kernel to /boot anymore, this is done by mkinitcpio. https://lists.archlinux.org/pipermail/arch-announce/2019-November/000397.html This changes the hooks to watch for vmlinuz files in /usr/lib/modules, just like mkinitcpio hook does.
-rw-r--r--10-linux-modules-post.hook4
-rw-r--r--10-linux-modules-pre.hook5
-rw-r--r--PKGBUILD12
3 files changed, 9 insertions, 12 deletions
diff --git a/10-linux-modules-post.hook b/10-linux-modules-post.hook
index 4a7d349069e6..d58444ccff9b 100644
--- a/10-linux-modules-post.hook
+++ b/10-linux-modules-post.hook
@@ -1,7 +1,7 @@
[Trigger]
Operation = Upgrade
-Type = File
-Target = boot/vmlinuz*
+Type = Path
+Target = usr/lib/modules/*/vmlinuz
[Action]
Description = Restoring Linux kernel modules...
diff --git a/10-linux-modules-pre.hook b/10-linux-modules-pre.hook
index 727c2ed1eb60..bb00c54f0670 100644
--- a/10-linux-modules-pre.hook
+++ b/10-linux-modules-pre.hook
@@ -1,8 +1,7 @@
[Trigger]
Operation = Upgrade
-Type = File
-Target = boot/vmlinuz*
-
+Type = Path
+Target = usr/lib/modules/*/vmlinuz
[Action]
Description = Saving Linux kernel modules...
diff --git a/PKGBUILD b/PKGBUILD
index c42d651b8ad7..1fb77c3946b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,11 @@ source=(
"10-linux-modules-pre.hook"
"UNLICENSE"
)
-sha256sums=(
- '4169b44c297ddb7aad2220c6eba7c7942e3396f92528c59617955ab5560cb4cf'
- '5d947290ef8c94b33c79c531e5615f4c9bea38e7649092d34af3bf0af5b1ca24'
- '53f099942790b209fabf757b97c2fa9ab6e309e11c47febf8e120fb9f5fe8adf'
- 'ca081465b5f2de547539fde2832932772058c34dd9f3178e33717b383eb76c9b'
- '7e12e5df4bae12cb21581ba157ced20e1986a0508dd10d0e8a4ab9a4cf94e85c'
- )
+sha256sums=('4169b44c297ddb7aad2220c6eba7c7942e3396f92528c59617955ab5560cb4cf'
+ '5d947290ef8c94b33c79c531e5615f4c9bea38e7649092d34af3bf0af5b1ca24'
+ '1161c1462c59acad138b9dd4b5befe7044105c6486cbfc71612139c3ab7f44ff'
+ '68b5e26debc6a20c02279980f37201a03cc6b79219af4a596fa497107b9698b3'
+ '7e12e5df4bae12cb21581ba157ced20e1986a0508dd10d0e8a4ab9a4cf94e85c')
package() {
install -Dm644 'linux-modules-cleanup.conf' "${pkgdir}/usr/lib/tmpfiles.d/linux-modules-cleanup.conf"