aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaber-nyan2019-03-29 18:19:35 +0300
committersaber-nyan2019-03-29 18:22:58 +0300
commitd95e1d63a6a16fd6dc6c9d5a5fc65ade9931f269 (patch)
treedc8787d27c42c948448503858f9bf89b57140188
parenteabd3ea8ebe6486739341fbc4061dab938624867 (diff)
downloadaur-d95e1d63a6a16fd6dc6c9d5a5fc65ade9931f269.tar.gz
Added license, fixed #5
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--10-linux-modules-post.hook2
-rw-r--r--10-linux-modules-pre.hook2
-rw-r--r--PKGBUILD15
-rw-r--r--UNLICENSE24
6 files changed, 42 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83185926c274..089d23666c93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = kernel-modules-hook
pkgdesc = Keeps your system fully functional after a kernel upgrade
- pkgver = 0.1.4
+ pkgver = 0.1.5
pkgrel = 1
url = https://github.com/saber-nyan/kernel-modules-hook
install = kernel-modules-hook.install
arch = any
- license = unknown
+ license = UNLICENSE
depends = rsync
source = linux-modules-cleanup.conf
source = linux-modules-cleanup.service
source = 10-linux-modules-post.hook
source = 10-linux-modules-pre.hook
+ source = UNLICENSE
sha256sums = 4169b44c297ddb7aad2220c6eba7c7942e3396f92528c59617955ab5560cb4cf
sha256sums = 5d947290ef8c94b33c79c531e5615f4c9bea38e7649092d34af3bf0af5b1ca24
- sha256sums = b8b5e939c49e77fb7a12cd4cd9743951a949ba6c48ca18e4f9d55653e9e58da2
- sha256sums = dbb765909596454d651023fdde2fc97b6ab26733fae39f5a45f4ae235681d4e6
+ sha256sums = 53f099942790b209fabf757b97c2fa9ab6e309e11c47febf8e120fb9f5fe8adf
+ sha256sums = ca081465b5f2de547539fde2832932772058c34dd9f3178e33717b383eb76c9b
+ sha256sums = 7e12e5df4bae12cb21581ba157ced20e1986a0508dd10d0e8a4ab9a4cf94e85c
pkgname = kernel-modules-hook
diff --git a/.gitignore b/.gitignore
index 06d9789e666f..6febc73edfc0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -17,3 +17,4 @@ linux-modules-cleanup.conf
linux-modules-cleanup.service
10-linux-modules-post.hook
10-linux-modules-pre.hook
+UNLICENSE
diff --git a/10-linux-modules-post.hook b/10-linux-modules-post.hook
index c37f9f63fb0f..4a7d349069e6 100644
--- a/10-linux-modules-post.hook
+++ b/10-linux-modules-post.hook
@@ -8,4 +8,4 @@ Description = Restoring Linux kernel modules...
When = PostTransaction
Depends = coreutils
Depends = rsync
-Exec = /bin/sh -xc 'KVER="${KVER:-$(uname -r)}"; if test -e "/lib/modules/backup/${KVER}"; then rsync -AHXal --ignore-existing "/lib/modules/backup/${KVER}" /lib/modules/; fi; rm -rf /lib/modules/backup'
+Exec = /bin/sh -xc 'KVER="${KVER:-$(uname -r)}"; if test -e "/usr/lib/modules/backup/${KVER}"; then rsync -AHXal --ignore-existing "/usr/lib/modules/backup/${KVER}" /usr/lib/modules/; fi; rm -rf /usr/lib/modules/backup'
diff --git a/10-linux-modules-pre.hook b/10-linux-modules-pre.hook
index 5002b3491732..727c2ed1eb60 100644
--- a/10-linux-modules-pre.hook
+++ b/10-linux-modules-pre.hook
@@ -8,4 +8,4 @@ Target = boot/vmlinuz*
Description = Saving Linux kernel modules...
When = PreTransaction
Depends = rsync
-Exec = /bin/sh -c 'KVER="${KVER:-$(uname -r)}"; if test -e "/lib/modules/${KVER}"; then rsync -AHXal --delete-after "/lib/modules/${KVER}" /lib/modules/backup/; fi'
+Exec = /bin/sh -c 'KVER="${KVER:-$(uname -r)}"; if test -e "/usr/lib/modules/${KVER}"; then rsync -AHXal --delete-after "/usr/lib/modules/${KVER}" /usr/lib/modules/backup/; fi'
diff --git a/PKGBUILD b/PKGBUILD
index 59b6cc0f0c8b..c42d651b8ad7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: saber-nyan <saber-nyan@ya.ru>
# Hooks: https://www.reddit.com/r/archlinux/comments/4zrsc3/keep_your_system_fully_functional_after_a_kernel/d6yin0r/
pkgname=kernel-modules-hook
-pkgver=0.1.4
+pkgver=0.1.5
pkgrel=1
pkgdesc="Keeps your system fully functional after a kernel upgrade"
arch=('any')
url="https://github.com/saber-nyan/kernel-modules-hook"
-license=('unknown')
+license=('UNLICENSE')
depends=('rsync')
install="${pkgname}.install"
source=(
@@ -14,12 +14,14 @@ source=(
"linux-modules-cleanup.service"
"10-linux-modules-post.hook"
"10-linux-modules-pre.hook"
+ "UNLICENSE"
)
sha256sums=(
- "4169b44c297ddb7aad2220c6eba7c7942e3396f92528c59617955ab5560cb4cf"
- "5d947290ef8c94b33c79c531e5615f4c9bea38e7649092d34af3bf0af5b1ca24"
- "b8b5e939c49e77fb7a12cd4cd9743951a949ba6c48ca18e4f9d55653e9e58da2"
- "dbb765909596454d651023fdde2fc97b6ab26733fae39f5a45f4ae235681d4e6"
+ '4169b44c297ddb7aad2220c6eba7c7942e3396f92528c59617955ab5560cb4cf'
+ '5d947290ef8c94b33c79c531e5615f4c9bea38e7649092d34af3bf0af5b1ca24'
+ '53f099942790b209fabf757b97c2fa9ab6e309e11c47febf8e120fb9f5fe8adf'
+ 'ca081465b5f2de547539fde2832932772058c34dd9f3178e33717b383eb76c9b'
+ '7e12e5df4bae12cb21581ba157ced20e1986a0508dd10d0e8a4ab9a4cf94e85c'
)
package() {
@@ -27,4 +29,5 @@ package() {
install -Dm644 'linux-modules-cleanup.service' "${pkgdir}/usr/lib/systemd/system/linux-modules-cleanup.service"
install -Dm644 '10-linux-modules-post.hook' "${pkgdir}/usr/share/libalpm/hooks/10-linux-modules-post.hook"
install -Dm644 '10-linux-modules-pre.hook' "${pkgdir}/usr/share/libalpm/hooks/10-linux-modules-pre.hook"
+ install -Dm644 'UNLICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/UNLICENSE"
}
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>