summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBiteDasher2021-08-24 14:46:25 +0300
committerBiteDasher2021-08-24 14:46:25 +0300
commit5cf48bf0ed9df8f784ca8119db8536c4c79b7d3e (patch)
treec0dc1400934a10a1e41298f43450a4c38ea01a50
downloadaur-5cf48bf0ed9df8f784ca8119db8536c4c79b7d3e.tar.gz
First release of kesboot-git
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f130ec7ad9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kesboot-git
+ pkgdesc = Script for automating work with EFI Kernel Stub (linux)
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/BiteDasher/kesboot
+ arch = x86_64
+ license = MIT
+ depends = efibootmgr
+ depends = sed
+ depends = grep
+ depends = util-linux
+ depends = coreutils
+ source = kesboot-git::git+https://github.com/BiteDasher/kesboot.git
+ sha512sums = SKIP
+
+pkgname = kesboot-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85000eddec1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Author: Artemii Sudakov <finziyr@yandex.ru>
+
+pkgname="kesboot-git"
+pkgver="1.0"
+pkgrel="1"
+pkgdesc='Script for automating work with EFI Kernel Stub (linux)'
+arch=('x86_64')
+url="https://github.com/BiteDasher/kesboot"
+license=('MIT')
+depends=('efibootmgr' 'sed' 'grep' 'util-linux' 'coreutils')
+source=("${pkgname}::git+https://github.com/BiteDasher/kesboot.git")
+sha512sums=("SKIP")
+package() {
+ cd "$srcdir/$pkgname"
+ export pkgdir
+ ./install.sh makepkg
+ install -Dm755 ./firstboot "$pkgdir"/usr/lib/setup-efi-boot
+}