aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTF2022-01-11 14:07:20 +0100
committerTF2022-01-11 14:20:58 +0100
commit3dae5b9b05cbef0714e3f7ff8dd9d7a147f12887 (patch)
tree577a398328a221b3c2ae88ebfa5f80ea7969e1f6
parentaa54cf2d659198dddc81ac58ecbaae2234d1acd1 (diff)
downloadaur-3dae5b9b05cbef0714e3f7ff8dd9d7a147f12887.tar.gz
improved conf handling
- export initial default conf on install - remove /etc/kesl/*.conf on removal Signed-off-by: TF <mail@sedi.one>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--kesl.ini7
-rw-r--r--kesl.install2
4 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88c2e15645c3..32f41857067f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,8 +22,8 @@ pkgbase = kesl
validpgpkeys = 6AFE173577C4CBD621DF217FD093435AA3ED2C4A
sha256sums = 44aef3025d9c440a87effa684169057d4a50d31dca9cc1e2e1d91a2cd42f6160
sha256sums = dc2c5c82cac25ba6ebf02220deb5c40fd2035bd24e74a62fb6d0bf3933e7db31
- sha256sums = 878302cee5d4aa28c5eac0f591ca3fe5fb751020ddd51e6a4d9d009c35e9eaac
- sha256sums = a662eefe3761c2816e96905e2efd4f3b36574ccc0a10e843390329affd222ebf
+ sha256sums = ee9df719cdba6ffb1928c6f8b3e32acf55de3d5a683128f0d9540676651f57a2
+ sha256sums = ec1dd039f4048589acb8987f3c4e7c52f659ef21483d65daf0cdc94756483821
pkgname = kesl
diff --git a/PKGBUILD b/PKGBUILD
index 15f2fab874d8..019e864643b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,8 +25,8 @@ source=( "https://products.s.kaspersky-labs.com/endpoints/keslinux10/${pkgver}/m
"kesl.ini")
sha256sums=('44aef3025d9c440a87effa684169057d4a50d31dca9cc1e2e1d91a2cd42f6160'
'dc2c5c82cac25ba6ebf02220deb5c40fd2035bd24e74a62fb6d0bf3933e7db31'
- '878302cee5d4aa28c5eac0f591ca3fe5fb751020ddd51e6a4d9d009c35e9eaac'
- 'a662eefe3761c2816e96905e2efd4f3b36574ccc0a10e843390329affd222ebf')
+ 'ee9df719cdba6ffb1928c6f8b3e32acf55de3d5a683128f0d9540676651f57a2'
+ 'ec1dd039f4048589acb8987f3c4e7c52f659ef21483d65daf0cdc94756483821')
validpgpkeys=('6AFE173577C4CBD621DF217FD093435AA3ED2C4A')
package_kesl() {
diff --git a/kesl.ini b/kesl.ini
index ff3a58cdc8c9..e111de946b6f 100644
--- a/kesl.ini
+++ b/kesl.ini
@@ -13,9 +13,8 @@ USE_KSN=No
# Start database update task during setup
# Note: upgrading the database can take a LONG time while any other pacman
-# jobs will wait until this has been finished. It is recommended to do
-# this manually instead:
-# /opt/kaspersky/kesl/bin/kesl-control --start-task Update --progress
+# jobs will wait until this has been finished. This package will auto-start
+# the update process in the background instead.
UPDATE_EXECUTE=No
# source for updates
@@ -40,5 +39,5 @@ USE_GUI=Yes
# Only users with the Administrator role have full access to Kaspersky
# Endpoint Security management by command line and GUI.
# Default (if unset) is none (i.e root only)
-# Package default is the user currently installing
+# Package default is to add the user who's currently installing
ADMIN_USER=@YOU@
diff --git a/kesl.install b/kesl.install
index e82290436960..bd655388e9e5 100644
--- a/kesl.install
+++ b/kesl.install
@@ -149,6 +149,7 @@ post_install(){
kesl-control -L --query
kesl_importconf
+ kesl_exportconf
kesl_updatedb
remove_tmp "$KTMP"
@@ -209,5 +210,6 @@ pre_remove(){
post_remove(){
#echo $FUNCNAME
rm -rf /etc/opt/kaspersky/ /opt/kaspersky/ /usr/share/licenses/kesl /var/opt/kaspersky
+ rm /etc/kesl/*.conf
}