summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-06-16 12:05:57 -0400
committerJames An2015-06-16 12:05:57 -0400
commitd370c215609b634860f2ec122a16e288fd764c0c (patch)
tree40813a8bd263be6bbfd7ef690516f3fa425e1599
downloadaur-d370c215609b634860f2ec122a16e288fd764c0c.tar.gz
Created new AUR package, kettu-git.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12148fecfd36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kettu-git
+ pkgdesc = Rewrite of the Transmission Web Client with jQuery, Sammy and Mustache
+ pkgver = r370.036767e
+ pkgrel = 1
+ url = https://github.com/endor/kettu
+ arch = i686
+ arch = x86_64
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = transmission-cli
+ provides = kettu=r370.036767e
+ conflicts = kettu
+ source = kettu::git+https://github.com/endor/kettu.git
+ md5sums = SKIP
+
+pkgname = kettu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c556836bda57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: James An <james@jamesan.ca>
+
+_pkgname=kettu
+pkgname="$_pkgname-git"
+pkgver=r370.036767e
+pkgrel=1
+pkgdesc='Rewrite of the Transmission Web Client with jQuery, Sammy and Mustache'
+arch=('i686' 'x86_64' 'any')
+url="https://github.com/endor/$_pkgname"
+license=('GPL')
+depends=(transmission-cli)
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("$_pkgname"::"git+https://github.com/endor/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ #~ The repo doesn't have any releases or other tagged commits.
+ #~ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cat << EOF >| $_pkgname.conf
+[Service]
+Environment=TRANSMISSION_WEB_HOME=/usr/share/webapps/$_pkgname
+EOF
+}
+
+package() {
+ install -Dm644 $_pkgname.conf "$pkgdir/usr/lib/systemd/system/transmission.service.d/$_pkgname.conf"
+ install -dm755 "$pkgdir/usr/share/webapps/$_pkgname"
+
+ cd "$_pkgname"
+ cp -a * "$pkgdir/usr/share/webapps/$_pkgname"
+}