summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-06-29 10:16:28 +0000
committerAntonio Rojas2019-06-29 10:16:28 +0000
commit61d4b3c5b16ec6b517d66b6a7fb0c38d09b677d5 (patch)
treec94e87b7d6676e4142116c2614f6bc46df897d06
downloadaur-61d4b3c5b16ec6b517d66b6a7fb0c38d09b677d5.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f858a80b410
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = keurocalc
+ pkgdesc = Utility to handle currency conversions between European currencies
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://kde.org/applications/office/org.kde.keurocalc
+ arch = x86_64
+ license = GPL2
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ depends = kio
+ depends = hicolor-icon-theme
+ source = https://download.kde.org/stable/keurocalc/keurocalc-1.3.0.tar.xz
+ sha256sums = 964a9b358f77658b9776226c519b7aa10610fd6d8cdd8c53b8439a22cb93812a
+
+pkgname = keurocalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3d61b787204
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=keurocalc
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Utility to handle currency conversions between European currencies"
+arch=(x86_64)
+url="https://kde.org/applications/office/org.kde.keurocalc"
+license=(GPL2)
+depends=(kio hicolor-icon-theme)
+makedepends=(extra-cmake-modules kdoctools)
+source=("https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz")
+sha256sums=('964a9b358f77658b9776226c519b7aa10610fd6d8cdd8c53b8439a22cb93812a')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}