aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack O'Connor2016-02-10 17:53:06 -0500
committerJack O'Connor2016-02-10 18:12:26 -0500
commit20a9abb4f01e2d28ddd045be360f002f4b313528 (patch)
treee6dfa54f34f2efc6795b1efe633410b5c5b3ea5c
downloadaur-20a9abb4f01e2d28ddd045be360f002f4b313528.tar.gz
initial package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
-rw-r--r--keybase.install13
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba3cbbd01f15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Feb 10 23:12:11 UTC 2016
+pkgbase = keybase-git
+ pkgdesc = the Keybase Go client, filesystem, and GUI
+ pkgver = 1.0.11_20160210230626+674c855
+ pkgrel = 1
+ install = keybase.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = go
+ makedepends = npm
+ makedepends = git
+ depends = fuse
+ conflicts = keybase
+ conflicts = keybase-release
+ source = git+ssh://git@github.com/keybase/client
+ source = git+ssh://git@github.com/keybase/kbfs-beta
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = keybase-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c96baab4c6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jack O'Connor <oconnor663@gmail.com>
+
+pkgname=keybase-git
+pkgdesc='the Keybase Go client, filesystem, and GUI'
+license=('BSD')
+pkgver=1.0.11_20160210230626+674c855
+pkgver() {
+ "$srcdir/client/packaging/version.sh" prerelease | sed 's/-/_/g'
+}
+pkgrel=1
+arch=('i686' 'x86_64')
+depends=(fuse)
+makedepends=(go npm git)
+# keybase-release is a deprecated AUR package
+conflicts=(keybase keybase-release)
+source=(
+ 'git+ssh://git@github.com/keybase/client'
+ 'git+ssh://git@github.com/keybase/kbfs-beta'
+)
+md5sums=('SKIP' 'SKIP')
+install=keybase.install
+
+build() {
+ cp -r "$srcdir/kbfs-beta/kbfs" "$srcdir/kbfs"
+ client/packaging/linux/build_binaries.sh prerelease build_dir
+}
+
+package() {
+ if [ "$CARCH" = x86_64 ] ; then
+ debian_arch=amd64
+ else
+ debian_arch=i386
+ fi
+ cp -r "$srcdir/build_dir/binaries/$debian_arch"/* "$pkgdir"
+}
diff --git a/keybase.install b/keybase.install
new file mode 100644
index 000000000000..0072c06ab63d
--- /dev/null
+++ b/keybase.install
@@ -0,0 +1,13 @@
+post_install() {
+ if [ -e /opt/keybase/post_install.sh ] ; then
+ # Until KBFS is in the production packages, this script doesn't exist.
+ /opt/keybase/post_install.sh
+ fi
+}
+
+post_upgrade() {
+ if [ -e /opt/keybase/post_install.sh ] ; then
+ # Until KBFS is in the production packages, this script doesn't exist.
+ /opt/keybase/post_install.sh
+ fi
+}