aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeronhaye2019-11-07 11:25:15 -0500
committerHeronhaye2019-11-07 11:31:45 -0500
commit7daae935b392f4dc51a21b5cc69783dbaf441561 (patch)
tree7cd4b6d434078a23233efc6692207b867d108579
parent08d7983f4a94c6480dc04c5a5f2175cf459f4ae6 (diff)
downloadaur-7daae935b392f4dc51a21b5cc69783dbaf441561.tar.gz
Update conflicts and provides fields
-rw-r--r--.SRCINFO10
-rw-r--r--Makefile1
-rw-r--r--PKGBUILD10
-rw-r--r--README.md19
4 files changed, 31 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0784083ce685..48975e1660bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = keybase-git
pkgdesc = the Keybase Go client, filesystem, and GUI
- pkgver = 3.0.0
+ pkgver = 4.8.0+33527.5750c3397a
pkgrel = 1
url = https://keybase.io
install = keybase.install
@@ -9,7 +9,7 @@ pkgbase = keybase-git
arch = armv7h
arch = aarch64
license = BSD
- makedepends = go
+ makedepends = go-pie
makedepends = yarn
makedepends = npm
makedepends = git
@@ -19,11 +19,15 @@ pkgbase = keybase-git
depends = libxss
depends = gtk2
depends = lsof
+ provides = keybase
+ provides = keybase-gui
+ provides = kbfs
conflicts = keybase
conflicts = keybase-release
conflicts = keybase-bin
+ conflicts = keybase-gui
+ conflicts = kbfs
source = git+https://github.com/keybase/client
- source = git+https://github.com/keybase/kbfs
md5sums = SKIP
md5sums = SKIP
diff --git a/Makefile b/Makefile
index 20f455bb79f8..3abacbcacd2c 100644
--- a/Makefile
+++ b/Makefile
@@ -8,5 +8,4 @@ push: check-srcinfo-diff
git push origin master
push-aur: check-srcinfo-diff
- git remote set-url --add aur https://aur.archlinux.org/keybase-git.git/
git push aur master
diff --git a/PKGBUILD b/PKGBUILD
index eecd15428e04..9a09af3bebd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Keybase <code@keybase.io>
+# Maintainer: Keybase <linux-packages@keybase.io>
# Contributor: Jack O'Connor <oconnor663@gmail.com>
pkgname=keybase-git
pkgdesc='the Keybase Go client, filesystem, and GUI'
license=('BSD')
url='https://keybase.io'
-pkgver=3.0.0
+pkgver=4.8.0+33527.5750c3397a
pkgver() {
"$srcdir/client/packaging/linux/arch/keybase_git_version.sh"
}
@@ -13,12 +13,12 @@ pkgrel=1
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
depends=(fuse gconf libxss gtk2 lsof) # don't change this without changing the SRCINFO template too,
# and the keybase-bin files in keybase/client/packaging/linux/arch
-makedepends=(go yarn npm git rsync)
+makedepends=(go-pie yarn npm git rsync)
+provides=(keybase keybase-gui kbfs)
# keybase-release is a deprecated AUR package
-conflicts=(keybase keybase-release keybase-bin)
+conflicts=(keybase keybase-release keybase-bin keybase-gui kbfs)
source=(
'git+https://github.com/keybase/client'
- 'git+https://github.com/keybase/kbfs'
)
md5sums=('SKIP' 'SKIP')
install=keybase.install
diff --git a/README.md b/README.md
index d81e6c84023b..e2968cf8d4c7 100644
--- a/README.md
+++ b/README.md
@@ -1,3 +1,22 @@
+Add a ssh remote
+
+```bash
+git remote add aur ssh://aur@aur.archlinux.org/keybase-git.git
+```
+
+Configure your `.ssh/config` to use the `aur` user:
+
+```
+HostName aur.archlinux.org
+ IdentityFile ~/.ssh/aur_id_ed25519
+ User aur
+```
+
+To update the version, run
+```bash
+makepkg --nobuild
+```
+
Before committing, you must rebuild .SRCINFO:
```bash
make build