summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormediocregopher2018-08-09 12:44:01 -0400
committermediocregopher2018-08-09 12:44:01 -0400
commitc311a761501a83f15f46eafe5c9fdbc2bf830ff8 (patch)
tree82f0e26f2b240a1e03154c97720f1077b7712be8
downloadaur-c311a761501a83f15f46eafe5c9fdbc2bf830ff8.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD69
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b2bbd18a6ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = keybase-git-arm
+ pkgdesc = the Keybase Go client, filesystem, and GUI (built for arm)
+ pkgver = 1.0.27+15115.8169d666e
+ pkgrel = 0
+ url = https://keybase.io
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = go
+ makedepends = yarn
+ makedepends = npm
+ makedepends = git
+ makedepends = rsync
+ makedepends = patch
+ depends = fuse
+ depends = gconf
+ depends = libxss
+ depends = gtk2
+ conflicts = keybase
+ conflicts = keybase-release
+ conflicts = keybase-bin
+ conflicts = keybase-git
+ source = git+https://github.com/keybase/client
+ source = git+https://github.com/keybase/kbfs
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = keybase-git-arm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99b00e916211
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Brian Picciano <mediocregopher@gmail.com>
+# Maintainer: Jack O'Connor <oconnor663@gmail.com>
+
+pkgname=keybase-git-arm
+pkgdesc='the Keybase Go client, filesystem, and GUI (built for arm)'
+license=('BSD')
+url='https://keybase.io'
+pkgver=1.0.27+15115.8169d666e
+pkgver() {
+ "$srcdir/client/packaging/linux/arch/keybase_git_version.sh"
+}
+pkgrel=0
+arch=('armv7h' 'aarch64')
+depends=(fuse gconf libxss gtk2) # don't change this without changing the SRCINFO template too
+makedepends=(go yarn npm git rsync patch)
+# keybase-release is a deprecated AUR package
+conflicts=(keybase keybase-release keybase-bin keybase-git)
+source=(
+ 'git+https://github.com/keybase/client'
+ 'git+https://github.com/keybase/kbfs'
+)
+md5sums=('SKIP' 'SKIP')
+
+build() {
+ echo 'diff --git a/packaging/linux/build_binaries.sh b/packaging/linux/build_binaries.sh
+index b7b7e1d16..999636177 100755
+--- a/packaging/linux/build_binaries.sh
++++ b/packaging/linux/build_binaries.sh
+@@ -170,20 +170,7 @@ build_one_architecture() {
+ # resinit_nix.go and fail the i386 build
+ export CGO_ENABLED=1
+
+-if [ -z "${KEYBASE_SKIP_64_BIT:-}" ] ; then
+- export GOARCH=amd64
+- export debian_arch=amd64
+- export electron_arch=x64
+- build_one_architecture
+-else
+- echo SKIPPING 64-bit build
+-fi
+-
+-if [ -z "${KEYBASE_SKIP_32_BIT:-}" ] ; then
+- export GOARCH=386
+- export debian_arch=i386
+- export electron_arch=ia32
+- build_one_architecture
+-else
+- echo SKIPPING 32-bit build
+-fi
++export GOARCH=arm
++export debian_arch=arm64
++export electron_arch=arm64
++build_one_architecture' | (cd client && patch -p1)
+
+ "$srcdir/client/packaging/linux/build_binaries.sh" prerelease "$srcdir/build_dir"
+}
+
+package() {
+ # use sh so that glob works
+ sh -c "cp -r $srcdir/build_dir/binaries/arm64/* $pkgdir"
+}
+
+post_install() {
+ /opt/keybase/post_install.sh
+}
+
+post_upgrade() {
+ /opt/keybase/post_install.sh
+}