summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbluetail2025-03-07 01:57:18 +0100
committerbluetail2025-03-07 01:57:18 +0100
commite3f76259a98cc41d5fd507c1bee7239f9c742770 (patch)
treec486e1c44ada1e9e31e865f6c596ee1a017904d0
parent34f1d42e0768ce8cab0d9fdc7ad9a12460145e1e (diff)
downloadaur-e3f76259a98cc41d5fd507c1bee7239f9c742770.tar.gz
clean up
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7498216f4c4..c455b40fd411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,14 @@ arch=('x86_64')
url="https://ddrkirby.com/games/key-blox/"
license=('Apache')
depends=('glibc')
-source=("https://ddrkirby.com/games/key-blox/KeyBlox_v1_07_linux.tar.gz"
+source=("https://ddrkirby.com/games/key-blox/KeyBlox_v${pkgver//./_}_linux.tar.gz"
"https://www.apache.org/licenses/LICENSE-2.0.txt") # Apache License source
sha256sums=('ca118627aea6d95d8935599c3ad78a0a25d1618e08cb903c1dd5b773b42e532e'
'cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30')
package() {
+ set -e # Exit immediately if a command exits with a non-zero status
+
cd "$srcdir/KeyBlox"
# Create /opt/keyblox directory and install all files
@@ -24,8 +26,10 @@ package() {
# Create a launcher script in /usr/bin
install -Dm755 /dev/null "$pkgdir/usr/bin/keyblox"
- echo '#!/bin/bash' > "$pkgdir/usr/bin/keyblox"
- echo '/opt/keyblox/KeyBlox "$@"' >> "$pkgdir/usr/bin/keyblox"
+ cat <<EOF > "$pkgdir/usr/bin/keyblox"
+#!/bin/bash
+exec /opt/keyblox/KeyBlox "\$@"
+EOF
chmod +x "$pkgdir/usr/bin/keyblox"
# Create a desktop entry for the game
@@ -33,9 +37,12 @@ package() {
cat <<EOF > "$pkgdir/usr/share/applications/keyblox.desktop"
[Desktop Entry]
Name=KeyBlox
+GenericName=Puzzle Game
+Comment=A challenging puzzle game inspired by Tetris: The Grand Master series.
Exec=/usr/bin/keyblox
Icon=/opt/keyblox/img/icon.png
Type=Application
-Categories=Game;
+Terminal=false
+Categories=Game;PuzzleGame;
EOF
}