summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvid Norlander2023-02-19 17:07:31 +0100
committerArvid Norlander2023-02-19 17:07:31 +0100
commit9243189d0dc6753810a0cf2cadc458aeb7aeb34b (patch)
tree8c19615fffc3e72c3b2c289b9b75ada1f3ed82ed
downloadaur-9243189d0dc6753810a0cf2cadc458aeb7aeb34b.tar.gz
Create repository
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..deddbc1dada9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = keyboard-backlightd
+ pkgdesc = Automatic keyboard backlight management on Thinkpads
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/VorpalBlade/keyboard-backlightd
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ depends = libevdev
+ backup = etc/conf.d/keyboard-backlightd
+ source = keyboard-backlightd-0.1.0.tar.gz::https://static.crates.io/crates/keyboard-backlightd/keyboard-backlightd-0.1.0.crate
+ sha256sums = 10f4cab8a98ea914c0a351b6c16c01532b780b02613c3410fe6dd513756127ee
+
+pkgname = keyboard-backlightd
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4a595dcdcc28
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.zst
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3f733ca668d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=keyboard-backlightd
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Automatic keyboard backlight management on Thinkpads"
+arch=(x86_64)
+url="https://github.com/VorpalBlade/keyboard-backlightd"
+license=('GPL3')
+depends=(libevdev)
+makedepends=(cargo)
+backup=(etc/conf.d/keyboard-backlightd)
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+sha256sums=('10f4cab8a98ea914c0a351b6c16c01532b780b02613c3410fe6dd513756127ee')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ make CARGO_FLAGS="--frozen --all-features"
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX=/usr ETCDIR=/etc install
+}