summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Honeycutt2021-05-13 15:15:52 -0600
committerAaron Honeycutt2021-05-13 15:15:52 -0600
commit87e0cdf12101b135d4a7e660c3e751d1e3b99dd7 (patch)
tree949578a9c2d334953d04e3d7c2a3e3e3ea54dac6
parent57f8a5e3738a655e3901af77a342fdf195982183 (diff)
downloadaur-87e0cdf12101b135d4a7e660c3e751d1e3b99dd7.tar.gz
update PKGBUILD makedepends and remove conflict line
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f7ec7a8fd3c..9bed8f38768f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
pkgname=('keyboard-configurator')
pkgbase=keyboard-configurator
pkgver=0.2.4
-pkgrel=1
+pkgrel=2
pkgdesc="Configures keymap and backlight of System76 keyboards."
arch=('x86_64')
url="https://github.com/pop-os/keyboard-configurator"
license=('GPL3')
-makedepends=('rust' 'dbus')
-conflicts=("$pkgbase-daemon-git")
+makedepends=('atk' 'at-spi2-atk' 'at-spi2-core' 'bzip2' 'cairo' 'dbus' 'expat' 'fontconfig' 'freetype2' 'fribidi' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'graphite' 'gtk3' 'harfbuzz' 'hidapi' 'libcap' 'libcloudproviders' 'libdatrie' 'libepoxy' 'libffi' 'libgcrypt' 'libgpg-error' 'libjpeg-error' 'libping' 'librender' 'libthai' 'libtiff' 'libx11' 'libxau' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxdmcp' 'libxext' 'libxfixes' 'libxi' 'libxinerama' 'libxkbcommon' 'libxrandr' 'lz4' 'pango' 'pcre' 'pixman' 'rust' 'systemd-libs' 'util-linux-libs' 'wayland' 'xz' 'zlib' 'zstd')
source=("$pkgbase-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver-beta.tar.gz")
sha256sums=('e50311da2da5d59f2ebf1f30c6067f8ffae5535cf0da3ad28cfcbb77a355cc70')
#noextract=('keyboard-configurator-0.2.4.tar.gz')
@@ -20,7 +19,7 @@ build() {
package_keyboard-configurator() {
pkgdesc="System76 GUI for managing keyboards"
- depends=('xz' 'hidapi' 'libudev0-shim')
+ depends=('xz' 'hidapi')
cd "$pkgbase-$pkgver-beta"
#make prefix="$pkgdir/usr/bin/" install