summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Honeycutt2023-10-27 07:07:47 -0600
committerAaron Honeycutt2023-10-27 07:09:54 -0600
commit070ee6985e207184df226f31e0dbc3e9468dfd3e (patch)
treef099fc46abb481509fe459028e2ce46401fb3fd7
parent772330385e0647353c253ae7f0f256d4642bfe42 (diff)
downloadaur-070ee6985e207184df226f31e0dbc3e9468dfd3e.tar.gz
Update build to match non-git version and pkgname
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f14855260100..da2b5467e7f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,13 +4,14 @@ pkgbase = keyboard-configurator-git
pkgrel = 2
url = https://github.com/pop-os/keyboard-configurator
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = cargo
makedepends = systemd
depends = gtk3
depends = hidapi
depends = xz
- source = keyboard-configurator-git::git+https://github.com/pop-os/keyboard-configurator
+ source = system76-keyboard-configurator-git::git+https://github.com/pop-os/keyboard-configurator
sha256sums = SKIP
-pkgname = keyboard-configurator-git
+pkgname = system76-keyboard-configurator-git
diff --git a/PKGBUILD b/PKGBUILD
index 25844845890f..17bbec4f13f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Aaron Honeycutt <aaron at system76 dot com>
-pkgname=keyboard-configurator-git
+pkgbase=keyboard-configurator-git
+pkgname=system76-keyboard-configurator-git
pkgver=1.3.10
pkgrel=2
pkgdesc="Configures keymap and backlight of System76 keyboards."
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/pop-os/keyboard-configurator"
license=('GPL3')
depends=('gtk3' 'hidapi' 'xz')
@@ -14,13 +15,13 @@ sha256sums=('SKIP')
prepare() {
cd "$pkgname"
export RUSTUP_TOOLCHAIN=stable
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ make vendor
}
build() {
cd "$pkgname"
export RUSTUP_TOOLCHAIN=stable
- make prefix=/usr
+ make VENDOR=1 prefix=/usr
}
package() {