summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Honeycutt2021-06-09 14:51:30 -0600
committerAaron Honeycutt2021-06-09 14:51:30 -0600
commitadc7d36c385dc7bff516a7a82a18dbf70006c1cd (patch)
treec60d815af1887362470e3f6a6a585838aeafd7d7
downloadaur-adc7d36c385dc7bff516a7a82a18dbf70006c1cd.tar.gz
init commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1902c19f32e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = keyboard-configurator
+ pkgdesc = Configures keymap and backlight of System76 keyboards.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/pop-os/keyboard-configurator
+ arch = x86_64
+ license = GPL3
+ depends = gtk3
+ depends = rust
+ depends = systemd
+
+pkgname = keyboard-configurator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e83e8ef0233
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Aaron Honeycutt <aaron at system76 dot com>
+pkgname=('keyboard-configurator')
+pkgbase=keyboard-configurator
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Configures keymap and backlight of System76 keyboards."
+arch=('x86_64')
+url="https://github.com/pop-os/keyboard-configurator"
+license=('GPL3')
+makedepends=('gtk3' 'rust' 'systemd')
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgbase"
+ make prefix=/usr
+}
+
+package_keyboard-configurator() {
+ pkgdesc="System76 GUI for managing keyboards"
+ depends=('xz' 'hidapi' 'gtk3')
+
+ cd "$pkgbase"
+ make prefix=/usr DESTDIR="$pkgdir/" install
+}
+