summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorproninyaroslav2015-07-13 18:01:57 +0300
committerproninyaroslav2015-07-13 18:01:57 +0300
commitea45259f91e43e74fadd17ae3283fc9a08d07de9 (patch)
treebceecca51703e48dfb0b4bf0e0e95a4b079a47aa
downloadaur-ea45259f91e43e74fadd17ae3283fc9a08d07de9.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
-rw-r--r--keyfuzz-0.2.tar.gzbin0 -> 97089 bytes
-rw-r--r--keyfuzz.systemd11
-rw-r--r--logitech_media_keyboard_600.keyfuzz30
-rw-r--r--support_by_id.patch21
6 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1221e33123ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = keyfuzz
+ pkgdesc = A Utility for manipulating the scancode/keycode translation tables of keyboard drivers
+ pkgver = 0.2
+ pkgrel = 9
+ url = http://0pointer.de/lennart/projects/keyfuzz/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = lynx
+ source = keyfuzz-0.2.tar.gz
+ source = keyfuzz.systemd
+ source = logitech_media_keyboard_600.keyfuzz
+ source = support_by_id.patch
+ sha256sums = d3cea89fc0a66e37026a947263f85f2075dbabda017ad60bf3d6a1bb63f56977
+ sha256sums = 231fb0c51d4a0f9d018d84851486c669a0c9a42debf08ce1d27beefcf91e29b3
+ sha256sums = de089c3769996398816f38ce68474be712e15a62a547f7f0e0f44842f7eb0c74
+ sha256sums = 5e1d8910f66053f269576e1fab94592e4df4e452a1a78153253b9df0fc8a129a
+
+pkgname = keyfuzz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74f622a6e775
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: yaroslav <proninyaroslav@mail.ru>
+# Contributor: Tom Kuther <archlinux@kuther.net>
+# Contributor: N30N <archlinux@alunamation.com>
+# Contributor: Aerion <this.id.was.still.free@aerion.co.uk>
+
+pkgname=keyfuzz
+pkgver=0.2
+pkgrel=9
+pkgdesc="A Utility for manipulating the scancode/keycode translation tables of keyboard drivers"
+url="http://0pointer.de/lennart/projects/keyfuzz/"
+license="GPL2"
+arch=("i686" "x86_64")
+depends=()
+makedepends=("lynx")
+
+# original source is down since 2014/08. It's small, so pack it in the aurball...
+#source=("${url}${pkgname}-${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}.systemd"
+ "logitech_media_keyboard_600.keyfuzz"
+ "support_by_id.patch")
+sha256sums=('d3cea89fc0a66e37026a947263f85f2075dbabda017ad60bf3d6a1bb63f56977'
+ '231fb0c51d4a0f9d018d84851486c669a0c9a42debf08ce1d27beefcf91e29b3'
+ 'de089c3769996398816f38ce68474be712e15a62a547f7f0e0f44842f7eb0c74'
+ '5e1d8910f66053f269576e1fab94592e4df4e452a1a78153253b9df0fc8a129a')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ patch -p0 < $srcdir/support_by_id.patch
+ ./configure --prefix=/usr \
+ --with-initdir=/usr/lib/systemd/scripts \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 ${srcdir}/keyfuzz.systemd "${pkgdir}/usr/lib/systemd/system/keyfuzz.service"
+ install -D -m644 ${srcdir}/logitech_media_keyboard_600.keyfuzz "${pkgdir}/etc/keyfuzz/logitech_media_keyboard_600.keyfuzz"
+}
+
+# vim: set noet ff=unix:
diff --git a/keyfuzz-0.2.tar.gz b/keyfuzz-0.2.tar.gz
new file mode 100644
index 000000000000..b314155d1e9d
--- /dev/null
+++ b/keyfuzz-0.2.tar.gz
Binary files differ
diff --git a/keyfuzz.systemd b/keyfuzz.systemd
new file mode 100644
index 000000000000..e67cdff8e5b6
--- /dev/null
+++ b/keyfuzz.systemd
@@ -0,0 +1,11 @@
+[Unit]
+Description=Keyboard keycode translation manipulation tool
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/usr/lib/systemd/scripts/keyfuzz start
+ExecReload=/usr/lib/systemd/scripts/keyfuzz reload
+
+[Install]
+WantedBy=multi-user.target
diff --git a/logitech_media_keyboard_600.keyfuzz b/logitech_media_keyboard_600.keyfuzz
new file mode 100644
index 000000000000..6b6ba65da4cb
--- /dev/null
+++ b/logitech_media_keyboard_600.keyfuzz
@@ -0,0 +1,30 @@
+### keyfuzz file for the Logitech Multimedia keyboard 600 special keys
+
+# All keycodes are shifted left by 8.
+
+# Search (244)
+0x9002d 236
+
+# VoIP (245)
+0x90001 237
+
+# Word Proccesing (246)
+0xc0184 238
+
+# Spreadsheet (247)
+0xc0186 239
+
+#Presentation (248)
+0xc0188 240
+
+# a (249)
+0x90049 241
+
+# b (250)
+0x9004a 242
+
+# c (251)
+0x9004b 243
+
+# d (252)
+0x9004c 244
diff --git a/support_by_id.patch b/support_by_id.patch
new file mode 100644
index 000000000000..69c627395095
--- /dev/null
+++ b/support_by_id.patch
@@ -0,0 +1,21 @@
+--- conf/keyfuzz.init.in.orig 2013-04-24 12:33:52.683242182 +0200
++++ conf/keyfuzz.init.in 2013-04-24 12:37:44.836295270 +0200
+@@ -30,9 +30,15 @@
+ echo -n "Loading input layer scancode tables: "
+ cd "@pkgsysconfdir@"
+ none=1
+- for E in event? ; do
+- if test -r "$E" ; then
+- "$KEYFUZZ" -s -d "$E" < "$E"
++ for OE in `find -type l -exec basename {} \;` ; do
++ if [[ -n "`echo $OE|egrep '^event'`" ]]; then
++ E=$OE
++ else
++ E=`basename $(readlink /dev/input/by-id/${OE})`
++ fi
++
++ if test -r "$OE" ; then
++ "$KEYFUZZ" -s -d "$E" < "$OE"
+ echo -n "$E "
+ none=0
+ fi