summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorahtn2019-06-10 20:41:13 +1000
committerahtn2019-06-10 20:42:43 +1000
commit415f8ed6aa7b94deb7df6c470f490fec39e4301b (patch)
treeb929ffc92cf16cded9965100f10033b50eb1f136
parent2525720340f9dd0b15f2a677fc258456a2cb18d4 (diff)
downloadaur-415f8ed6aa7b94deb7df6c470f490fec39e4301b.tar.gz
change pkgver() to get correct git version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c150c6695b6..933e2ff7271e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = keyplusd-git
pkgdesc = keyboard remapping tool that emulates keyplus firmware
- pkgver = v0.2.0.beta.r407.g37c9804
- pkgrel = 3
+ pkgver = 0.3.3.r77.gb9cc778
+ pkgrel = 1
url = https://github.com/ahtn/keyplus/tree/master/ports/linux
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 228d882d766f..c97a4cfcd4dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: jem <jem ΑΤ seethis DΟΤ link>
pkgname=keyplusd-git
_gitname=keyplus
-pkgver=v0.2.0.beta.r407.g37c9804
-pkgrel=3
+pkgver=0.3.3.r77.gb9cc778
+pkgrel=1
epoch=
pkgdesc="keyboard remapping tool that emulates keyplus firmware"
arch=('i686' 'x86_64')
@@ -31,7 +31,7 @@ validpgpkeys=()
pkgver() {
cd $_gitname
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --match "*.*.*" | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {