summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorahtn2019-06-10 16:47:02 +1000
committerahtn2019-06-10 16:47:02 +1000
commit9761ebe1bb397af8edf124358f066061d102b3a3 (patch)
tree5c2f511ea687771faff62d9a35c6f0688df42310
downloadaur-9761ebe1bb397af8edf124358f066061d102b3a3.tar.gz
init commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD48
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d502dc6ba50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = keyplusd-git
+ pkgdesc = keyboard remapping tool that emulates keyplus firmware
+ pkgver = v0.2.0.beta.r407.g37c9804
+ pkgrel = 1
+ url = https://github.com/ahtn/keyplus/tree/master/ports/linux
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ makedepends = python
+ depends = systemd
+ depends = libevdev
+ provides = keyplusd
+ conflicts = keyplusd
+ source = git+https://github.com/ahtn/keyplus.git
+ md5sums = SKIP
+
+pkgname = keyplusd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f505833d3271
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: jem <jem ΑΤ seethis DΟΤ link>
+pkgname=keyplusd-git
+_gitname=keyplus
+pkgver=v0.2.0.beta.r407.g37c9804
+pkgrel=1
+epoch=
+pkgdesc="keyboard remapping tool that emulates keyplus firmware"
+arch=('i686' 'x86_64')
+url="https://github.com/ahtn/keyplus/tree/master/ports/linux"
+license=('MIT')
+groups=()
+depends=('systemd' 'libevdev')
+makedepends=('git' 'make' 'gcc' 'python')
+checkdepends=()
+optdepends=()
+provides=('keyplusd')
+conflicts=('keyplusd')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ 'git+https://github.com/ahtn/keyplus.git'
+)
+md5sums=(
+ 'SKIP'
+)
+noextract=()
+validpgpkeys=()
+
+pkgver() {
+ cd $_gitname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_gitname
+ cd ports/linux
+ make PREFIX=/usr
+}
+
+package() {
+ cd $_gitname
+ cd ports/linux
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm 644 ../../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}