summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-06-05 03:41:21 +0200
committerml2020-06-05 03:41:21 +0200
commit0a267a090c37fbee3cfb55bbd914fe66326dcf58 (patch)
tree0631eb49e771ddd1f29db418ed4cc3abc43c06e2
parent0436ca1afe70ba437567fe6bf3a1f2df7114b063 (diff)
downloadaur-0a267a090c37fbee3cfb55bbd914fe66326dcf58.tar.gz
upgpkg: keys-pub 0.0.47-2
- drop gzip dependency - replace directive for plugin (though still broken)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD35
2 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2f6f346a403..aa0723c201b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = keys-pub
pkgdesc = keys.pub CLI client and service (keys, keysd)
pkgver = 0.0.47
- pkgrel = 1
+ pkgrel = 2
url = https://keys.pub/
arch = x86_64
arch = i686
license = MIT
makedepends = git
makedepends = go
- makedepends = gzip
depends = libfido2
optdepends = org.freedesktop.secrets: storing secrets
source = keys-pub-0.0.47.tar.gz::https://github.com/keys-pub/keys-ext/archive/v0.0.47.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index f17ad419c02a..8957f1386df7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,31 @@
# TODO systemd service
pkgname=keys-pub
pkgver=0.0.47
-pkgrel=1
+pkgrel=2
pkgdesc='keys.pub CLI client and service (keys, keysd)'
arch=('x86_64' 'i686')
url='https://keys.pub/'
license=('MIT')
depends=('libfido2')
-makedepends=('git' 'go' 'gzip')
+makedepends=('git' 'go')
optdepends=('org.freedesktop.secrets: storing secrets')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/keys-pub/keys-ext/archive/v${pkgver}.tar.gz")
sha256sums=('c9ada22e3bb7424c06838fa299288b5a2506ed7d659a5230ddc1e08a29f66cd2')
prepare() {
- cd "keys-ext-${pkgver}"
# lots of the components fetch an older version of themselves. not gonna use the replace directive
# on all of them. this is an upstream issue
- (
- cd auth/rpc
- go mod download
- )
- cd service
+ cd "keys-ext-${pkgver}/service"
sed -i 's#// \?\(replace github.com/keys-pub/keys-ext\)#\1#g' go.mod
go mod tidy
+
+ cd ../auth/rpc
+ echo 'replace github.com/keys-pub/keys-ext/auth/fido2 => ../fido2' >> go.mod
+ go mod tidy
}
build() {
- local _commit=$(zcat "${pkgname}-${pkgver}.tar.gz" | git get-tar-commit-id)
+ local _commit=$(bsdcat "${pkgname}-${pkgver}.tar.gz" | git get-tar-commit-id)
local -a x=(
main.version="$pkgver"
main.commit="${_commit:?}"
@@ -42,22 +41,18 @@ build() {
export CGO_CXXFLAGS="$CXXFLAGS"
export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
- (
- cd auth/rpc
- go build -o ../../fido2.so -buildmode=plugin ./plugin
- )
cd service
go build -o .. -ldflags "${x[*]/#/-X=}" ./{keys,keysd}
+
+ cd ../auth/rpc
+ go build -o ../../fido2.so -buildmode=plugin ./plugin
}
check() {
- cd "keys-ext-${pkgver}"
- (
- cd auth/rpc
- go test -failfast -short ./...
- )
- cd service
- go test -short ./...
+ cd "keys-ext-${pkgver}/service"
+ go test -failfast -short ./...
+ cd ../auth/rpc
+ go test -failfast -short ./...
}
package() {