summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErhan SAHIN2015-06-10 00:29:41 +0300
committerErhan SAHIN2015-06-10 00:29:41 +0300
commit102b1e9cfc4a691f133be19512f6eba43229303f (patch)
treedf68cdc673cb96c00b52944a6684e054d890122a
downloadaur-102b1e9cfc4a691f133be19512f6eba43229303f.tar.gz
Initial import
-rw-r--r--.SRCINFO61
-rw-r--r--PKGBUILD88
-rw-r--r--keystone.install18
-rw-r--r--keystone.service9
4 files changed, 176 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8542e004aae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,61 @@
+pkgbase = keystone-kilo
+ pkgdesc = OpenStack Identity
+ pkgver = 2015.1.0
+ pkgrel = 1
+ url = https://launchpad.net/keystone/
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ source = https://launchpad.net/keystone/kilo/2015.1.0/+download/keystone-2015.1.0.tar.gz
+ source = keystone.service
+ md5sums = 8f0794ce2e8f15561f188278919ade4f
+ md5sums = 4af52db88c8a5ca56ae26aefcd1c4828
+
+pkgname = keystone-kilo
+ pkgdesc = OpenStack Identity - Daemon
+ install = keystone.install
+ depends = python2-keystone-kilo
+ conflicts = keystone
+ conflicts = keystone-havana
+ conflicts = keystone-icehouse
+ backup = etc/keystone/keystone.conf
+
+pkgname = python2-keystone-kilo
+ pkgdesc = OpenStack Identity - Python library
+ depends = python2-pbr
+ depends = python2-webob
+ depends = python2-eventlet
+ depends = python2-greenlet
+ depends = python2-netaddr
+ depends = python2-paste-deploy
+ depends = python2-paste
+ depends = python2-routes
+ depends = python2-cryptography
+ depends = python2-six
+ depends = python2-sqlalchemy-kilo
+ depends = python2-migrate-kilo
+ depends = python2-passlib
+ depends = python2-iso8601
+ depends = python2-keystoneclient-kilo
+ depends = python2-keystonemiddleware-kilo
+ depends = python2-oslo-concurrency-kilo
+ depends = python2-oslo-config
+ depends = python2-oslo-messaging-kilo
+ depends = python2-oslo-db-kilo
+ depends = python2-oslo-i18n-kilo
+ depends = python2-oslo-log-kilo
+ depends = python2-oslo-middleware-kilo
+ depends = python2-oslo-policy-kilo
+ depends = python2-oslo-serialization-kilo
+ depends = python2-oslo-utils-kilo
+ depends = python2-oauthlib
+ depends = python2-pysaml2
+ depends = python2-dogpile-cache>=0.5.0
+ depends = python2-jsonschema
+ depends = python2-pycadf
+ depends = python2-posix_ipc
+ depends = python2-msgpack
+ conflicts = python2-keystone
+ conflicts = python2-keystone-havana
+ conflicts = python2-keystone-kilo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfec9eefe5a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,88 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgbase=keystone-kilo
+pkgname=('keystone-kilo' 'python2-keystone-kilo')
+pkgver=2015.1.0
+pkgrel=1
+arch=(any)
+url="https://launchpad.net/keystone/"
+license=('Apache')
+# makedepends=('python2-setuptools' 'python2-sphinx' 'python2-oslosphinx')
+makedepends=('python2-setuptools')
+pkgdesc="OpenStack Identity"
+source=("https://launchpad.net/keystone/kilo/$pkgver/+download/keystone-$pkgver.tar.gz"
+ "keystone.service")
+md5sums=('8f0794ce2e8f15561f188278919ade4f'
+ '4af52db88c8a5ca56ae26aefcd1c4828')
+
+build() {
+ cd "keystone-$pkgver"
+ /usr/bin/python2 setup.py build
+ /usr/bin/python2 setup.py install --root="$srcdir/tmp" --install-data="/" --optimize=1
+ cp -R etc/ $srcdir/tmp/
+}
+
+package_keystone-kilo() {
+ pkgdesc+=" - Daemon"
+ depends=('python2-keystone-kilo')
+ install=keystone.install
+ conflicts=('keystone' 'keystone-havana' 'keystone-icehouse')
+ backup=('etc/keystone/keystone.conf')
+ cd tmp
+ install -d ${pkgdir}/etc/keystone/
+ install -m 644 etc/default_catalog.templates ${pkgdir}/etc/keystone/default_catalog.templates
+ install -m 644 etc/keystone.conf.sample ${pkgdir}/etc/keystone/keystone.conf
+ install -m 644 etc/keystone-paste.ini ${pkgdir}/etc/keystone/
+ install -m 644 etc/logging.conf.sample ${pkgdir}/etc/keystone/logging.conf
+ install -m 644 etc/policy.json ${pkgdir}/etc/keystone/
+ install -m 644 etc/policy.v3cloudsample.json ${pkgdir}/etc/keystone/
+ install -d ${pkgdir}/usr/bin/
+ install -m 755 usr/bin/keystone-all ${pkgdir}/usr/bin/
+ install -m 755 usr/bin/keystone-manage ${pkgdir}/usr/bin/
+ install -d ${pkgdir}/usr/share/man/man1/
+ install -D -m 644 ${srcdir}/keystone.service ${pkgdir}/usr/lib/systemd/system/keystone.service
+ install -d -m 0770 ${pkgdir}/var/lib/keystone/
+ install -d -m 0770 ${pkgdir}/var/log/keystone/
+}
+
+package_python2-keystone-kilo() {
+ pkgdesc+=" - Python library"
+ depends=('python2-pbr'
+ 'python2-webob'
+ 'python2-eventlet'
+ 'python2-greenlet'
+ 'python2-netaddr'
+ 'python2-paste-deploy'
+ 'python2-paste'
+ 'python2-routes'
+ 'python2-cryptography'
+ 'python2-six'
+ 'python2-sqlalchemy-kilo'
+ 'python2-migrate-kilo'
+ 'python2-passlib'
+ 'python2-iso8601'
+ 'python2-keystoneclient-kilo'
+ 'python2-keystonemiddleware-kilo'
+ 'python2-oslo-concurrency-kilo'
+ 'python2-oslo-config'
+ 'python2-oslo-messaging-kilo'
+ 'python2-oslo-db-kilo'
+ 'python2-oslo-i18n-kilo'
+ 'python2-oslo-log-kilo'
+ 'python2-oslo-middleware-kilo'
+ 'python2-oslo-policy-kilo'
+ 'python2-oslo-serialization-kilo'
+ 'python2-oslo-utils-kilo'
+ 'python2-oauthlib'
+ 'python2-pysaml2'
+ 'python2-dogpile-cache>=0.5.0'
+ 'python2-jsonschema'
+ 'python2-pycadf'
+ 'python2-posix_ipc'
+ 'python2-msgpack')
+ conflicts=('python2-keystone' 'python2-keystone-havana' 'python2-keystone-kilo')
+
+ cd tmp
+ install -d ${pkgdir}/usr/lib/
+ cp -R usr/lib/ ${pkgdir}/usr/
+}
diff --git a/keystone.install b/keystone.install
new file mode 100644
index 000000000000..bde39c85ed0a
--- /dev/null
+++ b/keystone.install
@@ -0,0 +1,18 @@
+post_install() {
+ getent group keystone &>/dev/null || groupadd keystone >/dev/null
+ getent passwd keystone &>/dev/null || useradd -d /var/lib/keystone -g keystone -s /bin/false keystone >/dev/null
+ chmod 755 /etc/keystone
+ chown -R root:keystone /etc/keystone
+ chown keystone /var/log/keystone
+ chown keystone:keystone /var/lib/keystone
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ getent passwd keystone &>/dev/null && userdel keystone >/dev/null
+ getent group keystone &>/dev/null && groupdel keystone >/dev/null
+ true
+}
diff --git a/keystone.service b/keystone.service
new file mode 100644
index 000000000000..572c9f95e4e8
--- /dev/null
+++ b/keystone.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=keystone Identity API server
+
+[Service]
+ExecStart=/usr/bin/keystone-all
+User=keystone
+
+[Install]
+WantedBy=multi-user.target