summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Vybíhal2020-06-29 09:50:14 +0200
committerJosef Vybíhal2020-06-29 09:50:14 +0200
commitd53e82408803ba754e17daba61e9c12a17d9c560 (patch)
tree1f383229f17a4b28bd633930b0c8f3612585918f
parentb300b19eb67dcca8deaa9d3e813f5185ec98b33c (diff)
downloadaur-d53e82408803ba754e17daba61e9c12a17d9c560.tar.gz
Stop using upstreams gradlew (gradle-wrapper)
Use gradle directly without the wrapper used in upstream. It had negative consequence, that it pulled gradle .zip file from network in the build phase. With gradle 7.0, it might stop working as it uses some Deprecated Gradle features. But works for now with gradle 6.5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 033ce5318773..cdcbef45c87f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = keystore-explorer-git
pkgdesc = KeyStore Explorer is a free GUI replacement for the Java command-line utilities keytool and jarsigner.
- pkgver = v5.4.3+4+g0466346
- pkgrel = 1
+ pkgver = v5.4.3+5+gb86412f
+ pkgrel = 2
url = https://keystore-explorer.org/
arch = any
license = GPLv3
@@ -13,7 +13,7 @@ pkgbase = keystore-explorer-git
depends = desktop-file-utils
conflicts = keystore-explorer
conflicts = keystore-explorer-bin
- source = git+https://github.com/kaikramer/keystore-explorer.git
+ source = git+file:///tmp/keystore-explorer
sha256sums = SKIP
pkgname = keystore-explorer-git
diff --git a/PKGBUILD b/PKGBUILD
index 551342b4a924..d597a9ee419c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# If you think this package is shit, contact me with patch
pkgname=keystore-explorer-git
-pkgver=v5.4.3+4+g0466346
-pkgrel=1
+pkgver=v5.4.3+5+gb86412f
+pkgrel=2
pkgdesc="KeyStore Explorer is a free GUI replacement for the Java command-line utilities keytool and jarsigner."
arch=('any')
url="https://keystore-explorer.org/"
@@ -11,7 +11,7 @@ license=('GPLv3')
depends=('java-environment' 'bash' 'desktop-file-utils')
makedepends=( 'unzip' 'gradle' 'java-environment')
conflicts=('keystore-explorer' 'keystore-explorer-bin')
-source=('git+https://github.com/kaikramer/keystore-explorer.git')
+source=('git+file:///tmp/keystore-explorer')
sha256sums=('SKIP')
_pkgname=keystore-explorer
_short_pkgname=kse
@@ -24,7 +24,7 @@ pkgver() {
build() {
cd "${_pkgname}/${_short_pkgname}"
- sh gradlew zip
+ gradle zip # -g .gradle
cd "${srcdir}"
unzip -o ${_pkgname}/${_short_pkgname}/build/distributions/${_short_pkgname}-${_short_pkgver}.zip
}