summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-11 22:11:33 -0500
committerVincent Grande2021-01-11 22:11:33 -0500
commit489458e53f81dd39d559b6d300e483662a3aa658 (patch)
treeafb856af475ca5ad67d3a3fa625258c4f5b9df61
downloadaur-489458e53f81dd39d559b6d300e483662a3aa658.tar.gz
initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--reproducible.patch24
-rw-r--r--request-key.conf.patch21
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88a4cf8f5387
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = keyutils-git
+ pkgdesc = Linux Key Management Utilities
+ pkgver = 1.6.3
+ pkgrel = 1
+ url = https://www.kernel.org/
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ makedepends = git
+ depends = glibc
+ depends = sh
+ provides = libkeyutils.so
+ provides = keyutils
+ conflicts = keyutils
+ backup = etc/request-key.conf
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git
+ source = request-key.conf.patch
+ source = reproducible.patch
+ sha256sums = SKIP
+ sha256sums = 203c602c61ed94ccd423a0a453d74143d678c641a9a4486367576ee8af2cb8d6
+ sha256sums = 7bb7400b2b8c8f0288c86ec9191f8964a1e682745a204013d5fc7c2e1a253d8e
+
+pkgname = keyutils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09afce25d256
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=keyutils-git
+pkgver=1.6.3
+pkgrel=1
+pkgdesc='Linux Key Management Utilities'
+arch=('x86_64')
+url='https://www.kernel.org/'
+license=('GPL2' 'LGPL2.1')
+depends=('glibc' 'sh')
+makedepends=('git')
+provides=('libkeyutils.so' 'keyutils')
+conflicts=('keyutils')
+backup=('etc/request-key.conf')
+#validpgpkeys=('A86E54B0D5E1B4E0AB7C640FFBB7576BA7CB0B6B') # David Howells <dhowells@redhat.com>
+source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git"
+ 'request-key.conf.patch' 'reproducible.patch')
+sha256sums=('SKIP'
+ '203c602c61ed94ccd423a0a453d74143d678c641a9a4486367576ee8af2cb8d6'
+ '7bb7400b2b8c8f0288c86ec9191f8964a1e682745a204013d5fc7c2e1a253d8e')
+
+pkgver() {
+ cd keyutils
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd keyutils
+ # fix paths of binaries in /etc/request-key.conf
+ patch -Np0 -i ../request-key.conf.patch
+
+ # make keyutils reproducible
+ patch -Np1 -i ../reproducible.patch
+}
+
+build() {
+ cd keyutils
+ make CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" SBINDIR='/usr/bin' BINDIR='/usr/bin'
+}
+
+package() {
+ cd keyutils
+ make DESTDIR="${pkgdir}" SBINDIR='/usr/bin' BINDIR='/usr/bin' LIBDIR='/usr/lib' USRLIBDIR='/usr/lib' install
+}
diff --git a/reproducible.patch b/reproducible.patch
new file mode 100644
index 000000000000..db5cfe82c3b5
--- /dev/null
+++ b/reproducible.patch
@@ -0,0 +1,24 @@
+Adhere to the SOURCE_DATE_EPOCH standard and use it's date when set
+otherwise fall back to the default behaviour.
+
+Signed-off-by: Jelle van der Waa <jelle@vdwaa.nl>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 33a451e..9066d5d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -108,7 +108,7 @@ all: keyctl request-key key.dns_resolver
+ ###############################################################################
+ #RPATH = -Wl,-rpath,$(LIBDIR)
+
+-VCPPFLAGS := -DPKGBUILD="\"$(shell date -u +%F)\""
++VCPPFLAGS := -DPKGBUILD="\"$(date --utc --date="@${SOURCE_DATE_EPOCH:-$(date +%s)}" +%F)\""
+ VCPPFLAGS += -DPKGVERSION="\"keyutils-$(VERSION)\""
+ VCPPFLAGS += -DAPIVERSION="\"libkeyutils-$(APIVERSION)\""
+
+--
+2.21.0
+
diff --git a/request-key.conf.patch b/request-key.conf.patch
new file mode 100644
index 000000000000..9ab479631f54
--- /dev/null
+++ b/request-key.conf.patch
@@ -0,0 +1,21 @@
+--- request-key.conf.old 2013-05-28 15:34:10.966001242 +0200
++++ request-key.conf 2013-05-28 15:35:34.857969598 +0200
+@@ -31,11 +31,11 @@
+
+ #OP TYPE DESCRIPTION CALLOUT INFO PROGRAM ARG1 ARG2 ARG3 ...
+ #====== ======= =============== =============== ===============================
+-create dns_resolver * * /sbin/key.dns_resolver %k
+-create user debug:* negate /bin/keyctl negate %k 30 %S
+-create user debug:* rejected /bin/keyctl reject %k 30 %c %S
+-create user debug:* expired /bin/keyctl reject %k 30 %c %S
+-create user debug:* revoked /bin/keyctl reject %k 30 %c %S
+-create user debug:loop:* * |/bin/cat
++create dns_resolver * * /usr/bin/key.dns_resolver %k
++create user debug:* negate /usr/bin/keyctl negate %k 30 %S
++create user debug:* rejected /usr/bin/keyctl reject %k 30 %c %S
++create user debug:* expired /usr/bin/keyctl reject %k 30 %c %S
++create user debug:* revoked /usr/bin/keyctl reject %k 30 %c %S
++create user debug:loop:* * |/usr/bin/cat
+ create user debug:* * /usr/share/keyutils/request-key-debug.sh %k %d %c %S
+-negate * * * /bin/keyctl negate %k 30 %S
++negate * * * /usr/bin/keyctl negate %k 30 %S