summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorava1ar2016-02-04 00:09:03 -0500
committerava1ar2016-02-04 00:09:03 -0500
commitdd98474c2bf279b9b801f835017d073e012f9121 (patch)
tree4380a960472696d14f0f2eeae53c829060a80b56
parentf425444488785928ad80b70ffa468c3c492f14ea (diff)
downloadaur-dd98474c2bf279b9b801f835017d073e012f9121.tar.gz
depends/makedepends update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD52
2 files changed, 34 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91335a487231..2aa4510d0639 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Feb 4 05:07:55 UTC 2016
pkgbase = kfilebox
pkgdesc = KDE4 Dropbox client (with own daemon)
pkgver = 0.4.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gtgt/kfilebox
install = kfilebox.install
arch = i686
arch = x86_64
license = GPL
- depends = gettext
+ depends = kdebase-runtime
+ depends = qjson
provides = dropbox
+ conflicts = kfilebox-qt5-git
noextract = kfilebox-0.4.10.tar.gz}
source = https://github.com/gtgt/kfilebox/archive/0.4.10.tar.gz
- md5sums = 79d58aab7a342851cd961a0f784caefd
+ sha1sums = 640a5d48c9bcd9978c504564ee772a731d94ea1e
pkgname = kfilebox
diff --git a/PKGBUILD b/PKGBUILD
index 4c9a1d1c250d..e317d05afe38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,43 @@
-# Maintainer: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
-# Old-Mantainer: Gonzalo Seguel <gonzaloseguel@gmail.com>
+# Contibutor: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
+# Contributor: Gonzalo Seguel <gonzaloseguel@gmail.com>
+# Maintainer: ava1ar <mail(at)ava1ar(dot)me>
pkgname=kfilebox
pkgver=0.4.10
-pkgrel=1
+pkgrel=2
pkgdesc="KDE4 Dropbox client (with own daemon)"
arch=('i686' 'x86_64')
url="https://github.com/gtgt/kfilebox"
license=('GPL')
-depends=('gettext')
+depends=('kdebase-runtime' 'qjson')
+conflicts=('kfilebox-qt5-git')
provides=('dropbox')
-source=(https://github.com/gtgt/kfilebox/archive/${pkgver}.tar.gz)
+source=("https://github.com/gtgt/kfilebox/archive/${pkgver}.tar.gz")
install=$pkgname.install
noextract=(${pkgname}-${pkgver}.tar.gz})
-md5sums=('79d58aab7a342851cd961a0f784caefd')
+sha1sums=('640a5d48c9bcd9978c504564ee772a731d94ea1e')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- qmake-qt4
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ qmake-qt4
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # install binary
- install -m 755 -p -D "bin/kfilebox" "${pkgdir}/usr/bin/kfilebox"
- # create data directory
- install -m 755 -d "${pkgdir}/usr/share/kfilebox"
- # install notifyrc file
- install -m 644 -p -D "kfilebox.notifyrc" "${pkgdir}/usr/share/apps/kfilebox/kfilebox.notifyrc"
- # install desktop file
- install -m 644 -p -D "kfilebox.desktop" "${pkgdir}/usr/share/applications/kde4/kfilebox.desktop"
- # install locales
- for language in `ls "locale"`
- do
- if [ -e locale/$language/kfilebox.mo ]; then
- install -m 644 -p -D locale/$language/kfilebox.mo ${pkgdir}/usr/share/locale/$language/LC_MESSAGES/kfilebox.mo
- fi
- done
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # install binary
+ install -m 755 -p -D "bin/kfilebox" "${pkgdir}/usr/bin/kfilebox"
+ # create data directory
+ install -m 755 -d "${pkgdir}/usr/share/kfilebox"
+ # install notifyrc file
+ install -m 644 -p -D "kfilebox.notifyrc" "${pkgdir}/usr/share/apps/kfilebox/kfilebox.notifyrc"
+ # install desktop file
+ install -m 644 -p -D "kfilebox.desktop" "${pkgdir}/usr/share/applications/kde4/kfilebox.desktop"
+ # install locales
+ for language in `ls "locale"`
+ do
+ if [ -e locale/$language/kfilebox.mo ]; then
+ install -m 644 -p -D locale/$language/kfilebox.mo ${pkgdir}/usr/share/locale/$language/LC_MESSAGES/kfilebox.mo
+ fi
+ done
}