summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorava1ar2015-06-12 23:38:52 -0400
committerava1ar2015-06-12 23:38:52 -0400
commitf425444488785928ad80b70ffa468c3c492f14ea (patch)
treeffaa578cdcf08da814ad0dc70c0d37b563cfe043
downloadaur-f425444488785928ad80b70ffa468c3c492f14ea.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--kfilebox.install11
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91335a487231
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kfilebox
+ pkgdesc = KDE4 Dropbox client (with own daemon)
+ pkgver = 0.4.10
+ pkgrel = 1
+ url = https://github.com/gtgt/kfilebox
+ install = kfilebox.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gettext
+ provides = dropbox
+ noextract = kfilebox-0.4.10.tar.gz}
+ source = https://github.com/gtgt/kfilebox/archive/0.4.10.tar.gz
+ md5sums = 79d58aab7a342851cd961a0f784caefd
+
+pkgname = kfilebox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c9a1d1c250d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
+# Old-Mantainer: Gonzalo Seguel <gonzaloseguel@gmail.com>
+
+pkgname=kfilebox
+pkgver=0.4.10
+pkgrel=1
+pkgdesc="KDE4 Dropbox client (with own daemon)"
+arch=('i686' 'x86_64')
+url="https://github.com/gtgt/kfilebox"
+license=('GPL')
+depends=('gettext')
+provides=('dropbox')
+source=(https://github.com/gtgt/kfilebox/archive/${pkgver}.tar.gz)
+install=$pkgname.install
+noextract=(${pkgname}-${pkgver}.tar.gz})
+md5sums=('79d58aab7a342851cd961a0f784caefd')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # install binary
+ install -m 755 -p -D "bin/kfilebox" "${pkgdir}/usr/bin/kfilebox"
+ # create data directory
+ install -m 755 -d "${pkgdir}/usr/share/kfilebox"
+ # install notifyrc file
+ install -m 644 -p -D "kfilebox.notifyrc" "${pkgdir}/usr/share/apps/kfilebox/kfilebox.notifyrc"
+ # install desktop file
+ install -m 644 -p -D "kfilebox.desktop" "${pkgdir}/usr/share/applications/kde4/kfilebox.desktop"
+ # install locales
+ for language in `ls "locale"`
+ do
+ if [ -e locale/$language/kfilebox.mo ]; then
+ install -m 644 -p -D locale/$language/kfilebox.mo ${pkgdir}/usr/share/locale/$language/LC_MESSAGES/kfilebox.mo
+ fi
+ done
+}
diff --git a/kfilebox.install b/kfilebox.install
new file mode 100644
index 000000000000..85c6a9f0ad21
--- /dev/null
+++ b/kfilebox.install
@@ -0,0 +1,11 @@
+post_install() {
+ kbuildsycoca4
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}