summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorava1ar2016-02-03 23:52:36 -0500
committerava1ar2016-02-03 23:59:24 -0500
commit6c390f4c76953a7e1b56eb4ad79e313a532167e0 (patch)
tree089d286381b273f2b876ab9c029715abb1123742
downloadaur-6c390f4c76953a7e1b56eb4ad79e313a532167e0.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
-rw-r--r--kfilebox.install12
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10b28302695a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Feb 4 04:58:25 UTC 2016
+pkgbase = kfilebox-qt5-git
+ pkgdesc = KDE Dropbox client with own daemon (Qt5 branch)
+ pkgver = r130.5294287
+ pkgrel = 1
+ url = https://github.com/marcpayne/kfilebox
+ install = kfilebox.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake>2.8.12
+ depends = knotifications
+ depends = ki18n
+ depends = hicolor-icon-theme
+ provides = dropbox
+ conflicts = kfilebox
+ source = git+https://github.com/marcpayne/kfilebox.git#branch=qt5-kf5-port
+ sha1sums = SKIP
+
+pkgname = kfilebox-qt5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a9a262b02f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
+# Old-Mantainer: Gonzalo Seguel <gonzaloseguel@gmail.com>
+
+pkgname=kfilebox-qt5-git
+_pkgname=kfilebox
+pkgrel=1
+pkgver=r130.5294287
+pkgdesc="KDE Dropbox client with own daemon (Qt5 branch)"
+arch=('i686' 'x86_64')
+url="https://github.com/marcpayne/kfilebox"
+license=('GPL')
+depends=('knotifications' 'ki18n' 'hicolor-icon-theme')
+makedepends=('git' 'cmake>2.8.12')
+provides=('dropbox')
+conflicts=('kfilebox')
+source=(git+https://github.com/marcpayne/kfilebox.git#branch=qt5-kf5-port)
+install=${_pkgname}.install
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p ${_pkgname}/build
+}
+
+build() {
+ cd ${_pkgname}/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd ${_pkgname}/build
+ make DESTDIR=${pkgdir} install
+ # instal missing icon
+ install -Dm644 "${srcdir}"/${_pkgname}/img/${_pkgname}.png "${pkgdir}"/usr/share/${_pkgname}/${_pkgname}.png
+}
diff --git a/kfilebox.install b/kfilebox.install
new file mode 100644
index 000000000000..eb6dc2ecbe64
--- /dev/null
+++ b/kfilebox.install
@@ -0,0 +1,12 @@
+post_install() {
+ kbuildsycoca5
+ gtk-update-icon-cache
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}