summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-11-05 18:21:28 +0100
committerGustavo Alvarez2016-11-05 18:21:28 +0100
commit7872b72947779c776afd561e931316e08d503e91 (patch)
tree0ee6852a90819fb5bd004ddf6d0b26a583545283
downloadaur-7872b72947779c776afd561e931316e08d503e91.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c754e2e0c978
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Sat Nov 5 17:21:27 UTC 2016
+pkgbase = kfind-git
+ pkgdesc = KDE file find utility. (GIT version)
+ pkgver = 2.0.0.2355.af2bf52
+ pkgrel = 1
+ url = https://projects.kde.org/projects/kde/applications/kfind
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = karchive
+ makedepends = git
+ makedepends = python
+ depends = kdelibs4support
+ depends = hicolor-icon-theme
+ provides = kfind
+ conflicts = kdebase-kfind
+ conflicts = kfind
+ source = git://anongit.kde.org/kfind
+ sha256sums = SKIP
+
+pkgname = kfind-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8e9d48f844c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Antonio Rojas <arojas@archlinux,org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=kfind-git
+pkgver=2.0.0.2355.af2bf52
+pkgrel=1
+pkgdesc="KDE file find utility. (GIT version)"
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/kde/applications/kfind'
+license=('LGPL')
+depends=('kdelibs4support'
+ 'hicolor-icon-theme'
+ )
+makedepends=('extra-cmake-modules'
+ 'kdoctools'
+ 'karchive'
+ 'git'
+ 'python'
+ )
+conflicts=('kdebase-kfind'
+ 'kfind'
+ )
+provides=('kfind')
+source=('git://anongit.kde.org/kfind')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd kfind
+ _ver="$(cat CMakeLists.txt | grep -m1 'KFIND_VERSION' | cut -d '"' -f2)"
+ echo "${_ver}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kfind \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}