summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSascha Pfau2015-12-09 19:16:26 +0100
committerSascha Pfau2015-12-09 19:16:26 +0100
commit0e6962a391ea8dbd0e5b549a1f85878fe7e4f965 (patch)
treecae66e00ae589d5cdd3bb3bd5b4556037556722e
downloadaur-0e6962a391ea8dbd0e5b549a1f85878fe7e4f965.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70d78fb4d2d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Dec 9 18:09:57 UTC 2015
+pkgbase = kfritz
+ pkgdesc = A KDE program for users of AVMs Fritz!Box to get call signaling and other functions.
+ pkgver = 0.0.14
+ pkgrel = 1
+ url = https://github.com/jowi24/kfritz
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = automoc4
+ makedepends = cmake
+ depends = kdelibs>=4.3
+ depends = commoncpp2
+ source = https://github.com/jowi24/kfritz/releases/download/0.0.14/kfritz_0.0.14.orig.tar.gz
+ md5sums = 4f38bb545e5b1469215d261ad41e90e2
+
+pkgname = kfritz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bda0517a251
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sascha Pfau
+pkgname=kfritz
+pkgver=0.0.14
+pkgrel=1
+pkgdesc="A KDE program for users of AVMs Fritz!Box to get call signaling and other functions."
+arch=(i686 x86_64)
+url="https://github.com/jowi24/kfritz"
+license=('GPL2')
+depends=('kdelibs>=4.3' 'commoncpp2')
+makedepends=('automoc4' 'cmake')
+source=("https://github.com/jowi24/kfritz/releases/download/${pkgver}/kfritz_${pkgver}.orig.tar.gz")
+md5sums=('4f38bb545e5b1469215d261ad41e90e2')
+
+
+build() {
+ cd $srcdir/kfritz
+
+ #run cmake manually to set the correct CMAKE_INSTALL_PREFIX
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cd ..
+ LDFLAGS=""
+ make || return 1
+}
+
+
+package() {
+ cd $srcdir/kfritz/build
+ make DESTDIR=$pkgdir install || return 1
+
+ install -D -m644 $srcdir/kfritz/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+} \ No newline at end of file