summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Guilloux2019-10-07 20:51:58 +0200
committerNicolas Guilloux2019-10-07 20:51:58 +0200
commitfae1ede94b08c3bcb1312beaad01fc8e224d9ee5 (patch)
tree4bf1c242b5fc694ce9c97221d90891ab1d41fa69
downloadaur-fae1ede94b08c3bcb1312beaad01fc8e224d9ee5.tar.gz
First commit, version 1.1.1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--Makefile23
-rw-r--r--PKGBUILD31
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08f02e020c67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kget-integrator
+ pkgdesc = Integrate KGet Download Manager with Google Chrome, Chromium, Vivaldi, Opera and Firefox
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/NicolasGuilloux/KGet-Integrator
+ arch = any
+ license = GPL3
+ depends = python3
+ depends = kget
+ optdepends = kget-integrator-chrome: native messaging hosts for Google Chrome
+ optdepends = kget-integrator-chromium: native messaging hosts for Chromium and Vivaldi
+ optdepends = kget-integrator-opera: native messaging hosts for Opera
+ optdepends = kget-integrator-firefox: native messaging hosts for Firefox
+ source = kget-integrator-1.1.1::https://raw.githubusercontent.com/NicolasGuilloux/KGet-Integrator/v1.1.1/kget-integrator
+ md5sums = 29eb300bc60522c676b2ef466bfc6bb6
+
+pkgname = kget-integrator
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..401bf5b52163
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+kget-integrator* \ No newline at end of file
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..f4a1faabe6eb
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+version = 9add3366d25530d51d168608c54b5339b64d2a4e
+
+help:
+ @grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
+
+build:clear ## Build pakage
+ makepkg -s
+
+clear: ## Clear files
+ rm -rf ./pkg
+ rm -rf ./src
+ rm -f ./*.zip
+ rm -f ./*~
+ rm -f ./kget-integrator*
+
+pkgsum: ## update pkgsum with updpkgsums
+ updpkgsums
+
+release:clear pkgsum srcinfo ## Release preparation
+ git pull
+
+srcinfo: ## génération .SRCINFO
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5569918ba9d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer : Nover <nicolas.guilloux@protonmail.com>
+# Heavily inspired by https://aur.archlinux.org/packages/uget-integrator/
+
+pkgname=kget-integrator
+pkgdesc="Integrate KGet Download Manager"
+arch=('any')
+url="https://github.com/NicolasGuilloux/KGet-Integrator"
+license=('GPL3')
+depends=('python3' 'kget')
+makedepends=()
+pkgver=v1.1.1
+pkgrel=1
+source=("kget-integrator-$pkgver::https://raw.githubusercontent.com/NicolasGuilloux/KGet-Integrator/v$pkgver/kget-integrator")
+pkgdesc="Integrate KGet Download Manager with Google Chrome, Chromium, Vivaldi, Opera and Firefox"
+md5sums=('29eb300bc60522c676b2ef466bfc6bb6')
+optdepends=(
+ 'kget-integrator-chrome: native messaging hosts for Google Chrome'
+ 'kget-integrator-chromium: native messaging hosts for Chromium and Vivaldi'
+ 'kget-integrator-opera: native messaging hosts for Opera'
+ 'kget-integrator-firefox: native messaging hosts for Firefox'
+)
+
+build() {
+ cd "$srcdir"
+}
+
+package(){
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 "kget-integrator-$pkgver" "$pkgdir"/usr/bin/kget-integrator
+} \ No newline at end of file