summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCentRa2021-01-24 19:57:23 +0900
committerCentRa2021-01-24 19:57:23 +0900
commit439cc981b6b2599187e0cac507b685449d30f86e (patch)
treece5400927406348ac6cf47613e48a77521657363
downloadaur-439cc981b6b2599187e0cac507b685449d30f86e.tar.gz
warota
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD45
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df3e257e3b04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,9 @@
+pkgbase = kh-webstore
+ pkgver = 0.0.1
+ pkgrel = 1
+ arch = x86_64
+ license = Apache
+ source = https://github.com/CentRa-Linux/kh-webstore/releases/download/release/kh-webstore-0.0.1.tar.gz
+ md5sums = c25af2b64554532e2905e66c61e44d5c
+
+pkgname = kh-webstore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..645041bd4dbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=kh-webstore
+pkgver=0.0.1
+pkgrel=1
+epoch=
+pkgdesc=""
+arch=(x86_64)
+url=""
+license=('Apache')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/CentRa-Linux/kh-webstore/releases/download/release/kh-webstore-0.0.1.tar.gz")
+noextract=()
+md5sums=("c25af2b64554532e2905e66c61e44d5c")
+validpgpkeys=()
+
+build() {
+ sudo cp -rf "$pkgname-$pkgver" "/usr/share/kh-webstore"
+ cd "$pkgname-$pkgver"
+ sudo cp -rf "kh-webstore.desktop" "/usr/share/applications/kh-webstore.desktop"
+}
+
+package() {
+ mkdir $pkgdir/usr
+ mkdir $pkgdir/usr/share
+ mkdir $pkgdir/usr/share/applications
+ sudo cp -rf "$pkgname-$pkgver" "$pkgdir/usr/share/kh-webstore"
+ cd "$pkgname-$pkgver"
+ sudo cp -rf "kh-webstore.desktop" "$pkgdir/usr/share/applications/kh-webstore.desktop"
+}