summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2015-05-04 11:13:26 +0200
committerÉtienne Deparis2015-05-04 11:13:26 +0200
commitf0447b2dd79e7550050a8a122cc67c57e986facc (patch)
treec43b4eeb3d078e96dd4c65499f84c791346e273a
parentc0581b54ac0351e4098dbdba2be665dc5c645d8a (diff)
downloadaur-f0447b2dd79e7550050a8a122cc67c57e986facc.tar.gz
New pkgbuild version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
-rw-r--r--khal.install2
3 files changed, 29 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a85384e43b65..97bca485a4db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
-# Generated by makepkg 4.2.0
-# Sun Feb 8 14:57:31 UTC 2015
+# Generated by makepkg 4.2.1
+# Mon May 4 09:09:55 UTC 2015
pkgbase = khal-git
pkgdesc = Command line CalDav client
- pkgver = 0.5.0.r5.g09362ae
+ pkgver = 0.5.0.r145.g20a9640
pkgrel = 1
url = http://lostpackets.de/khal/
install = khal.install
arch = any
license = MIT
- makedepends = python2-setuptools
+ makedepends = python-setuptools
makedepends = git
- makedepends = python2-sphinxcontrib-newsfeed
- depends = python2-urwid
- depends = python2-xdg
- depends = python2-vdirsyncer
- depends = python2-dateutil
- depends = python2-configobj
- depends = python2-tzlocal
+ makedepends = python-sphinxcontrib-newsfeed
+ depends = python-urwid
+ depends = python-xdg
+ depends = vdirsyncer
+ depends = python-dateutil
+ depends = python-configobj
+ depends = python-tzlocal
+ depends = python-icalendar
depends = sqlite
provides = khal
conflicts = khal
diff --git a/PKGBUILD b/PKGBUILD
index 10dc3cc439c7..c566b6d36360 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,23 @@
pkgname=khal-git
_gitname=khal
-pkgver=0.5.0.r5.g09362ae
+pkgver=0.5.0.r145.g20a9640
pkgrel=1
pkgdesc="Command line CalDav client"
license=("MIT")
url="http://lostpackets.de/khal/"
+depends=('python-urwid' 'python-xdg' 'vdirsyncer' 'python-dateutil'
+ 'python-configobj' 'python-tzlocal' 'python-icalendar' 'sqlite')
+makedepends=('python-setuptools' 'git' 'python-sphinxcontrib-newsfeed')
+# I keep here python depencies...
# python2-click, python2-icalendar come with the python2-vdirsyncer dependancy
# python2-pytz comes with the python2-icalendar dependancy
-depends=('python2-urwid' 'python2-xdg' 'python2-vdirsyncer'
- 'python2-dateutil' 'python2-configobj' 'python2-tzlocal'
- 'sqlite')
+#depends=('python2-urwid' 'python2-xdg' 'python2-vdirsyncer'
+# 'python2-dateutil' 'python2-configobj' 'python2-tzlocal'
+# 'python2-icalendar' 'sqlite')
# Doesn't seems to be useful anymore...
# python2-requests' 'python2-certifi')
-makedepends=('python2-setuptools' 'git' 'python2-sphinxcontrib-newsfeed')
+#makedepends=('python2-setuptools' 'git' 'python2-sphinxcontrib-newsfeed')
source=("${_gitname}::git+https://github.com/geier/khal.git")
md5sums=('SKIP')
install='khal.install'
@@ -37,20 +41,20 @@ pkgver() {
build(){
cd "$srcdir/${_gitname}/doc"
# Fix to use python2
- sed -i 's/sphinx-build/sphinx-build2/g' Makefile
- sed -i 's/python/python2/' source/generate_config.py
- sed -i 's/python/python2/' source/Makefile
+ #sed -i 's/sphinx-build/sphinx-build2/g' Makefile
+ #sed -i 's/python/python2/' source/generate_config.py
+ #sed -i 's/python/python2/' source/Makefile
make man
}
package() {
cd "$srcdir/${_gitname}/"
- python2 setup.py install --root=$pkgdir
+ python setup.py install --root=$pkgdir
- install -D -m644 khal.conf.sample "${pkgdir}/etc/skel/khal.conf"
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/khal/LICENSE"
- install -D -m644 AUTHORS.txt "${pkgdir}/usr/share/licenses/khal/AUTHORS"
+ install -D -m644 khal.conf.sample "${pkgdir}/usr/share/doc/${_gitname}/examples/khal.conf"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+ install -D -m644 AUTHORS.txt "${pkgdir}/usr/share/licenses/${_gitname}/AUTHORS"
install -D -m644 doc/build/man/khal.1 "${pkgdir}/usr/share/man/man1/khal.1"
diff --git a/khal.install b/khal.install
index 0e6db42df72f..6aac984fb31e 100644
--- a/khal.install
+++ b/khal.install
@@ -6,6 +6,6 @@ post_install() {
post_upgrade() {
echo 'The configuration file has changed.'
- echo 'Please compare your own version in ~/.config/khal/khal.conf with the new one put in /etc/skel/khal.conf.'
+ echo 'Please compare your own version in ~/.config/khal/khal.conf with the new one put in /usr/share/doc/khal/examples/khal.conf.'
echo 'You may also need to delete your sqlite file (in ~/.config/khal/khal.db) to take into account any changes, which might have occured in the database schema.'
} \ No newline at end of file