summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2015-12-30 14:16:29 +0100
committerDavid Runge2015-12-30 14:16:29 +0100
commit82da0c890cb80adea268920ee723e2095cc56482 (patch)
tree82e633aa3cffc9effc7e3160286d1ed71f1e2727
parent1f6fdde75b125c7f2445995635fc0996833578d8 (diff)
downloadaur-82da0c890cb80adea268920ee723e2095cc56482.tar.gz
khard-git.install: Updating to reflect new templating possibilities. PKGBUILD: Updated to version > 0.6.3, changing location of example configuration file in source. Adding templating file from source. .SRCINFO: Updating to version > 0.6.3.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--khard-git.install4
3 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79b6324eac43..abce140bcae7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Dec 30 13:14:12 UTC 2015
pkgbase = khard-git
pkgdesc = Console CardDAV client
- pkgver = 0.6.2.r0.g5c23725
+ pkgver = 0.6.3.r4.g527e1ba
pkgrel = 1
url = https://github.com/scheibler/khard/
install = khard-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 1959725d088f..05a88734b16e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=khard-git
_gitname=khard
-pkgver=0.6.2.r0.g5c23725
+pkgver=0.6.3.r4.g527e1ba
pkgrel=1
pkgdesc="Console CardDAV client"
license=("GPL3")
@@ -31,7 +31,8 @@ build(){
package() {
cd "$srcdir/${_gitname}/"
python2 setup.py install --root=$pkgdir
- install -Dm 644 misc/khard.conf.example "${pkgdir}/usr/share/doc/khard/khard.conf.example"
+ install -Dm 644 misc/khard/khard.conf.example "${pkgdir}/usr/share/doc/khard/khard.conf.example"
+ install -Dm 644 misc/khard/template_for_contact_creation.yaml "${pkgdir}/usr/share/doc/khard/template_for_contact_creation.yaml"
install -Dm 644 misc/zsh/_khard "${pkgdir}/usr/share/zsh/site-functions/_khard"
install -Dm 644 AUTHORS "${pkgdir}/usr/share/doc/khard/AUTHORS"
install -Dm 644 CHANGES "${pkgdir}/usr/share/doc/khard/CHANGES"
diff --git a/khard-git.install b/khard-git.install
index 6fada6f88ee8..3040943e6c71 100644
--- a/khard-git.install
+++ b/khard-git.install
@@ -1,10 +1,12 @@
post_install() {
echo 'A sample and self explanatory configuration file has been put in /usr/share/doc/khard/khard.conf.example.'
echo 'Copy it to ~/.config/khard/khard.conf and edit it as needed.'
+ echo 'If you want to change the templates for contact creation take a look at /usr/share/doc/khard/template_for_contact_creation.yaml for reference.'
+ echo 'Then define the path to your own template file in your khard configuration file.'
}
post_upgrade() {
- local v up=0 confupgrades=(0.3.1 0.5.0 0.6.0 0.6.0.r1)
+ local v up=0 confupgrades=(0.3.1 0.5.0 0.6.0 0.6.0.r1 0.6.3)
for v in "${confupgrades[@]}"; do
if [ $(vercmp "$v" "$2") -eq 0 -o $(vercmp "$v" "$2") -eq -1 ]; then
up=1