summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkageru2021-07-08 13:21:09 +0200
committerkageru2021-07-08 13:30:59 +0200
commitfc27f4217435d6b3f667fd4f1868d708e6dcb304 (patch)
treee92b1daee3ce37cb5fdde2b4bdb78871d0e40395
downloadaur-fc27f4217435d6b3f667fd4f1868d708e6dcb304.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD37
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..390e1ed63fa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ki-shell-git
+ pkgdesc = Kotlin Language Interactive Shell
+ pkgver = 0.3.3.r14.g0cc592d
+ pkgrel = 1
+ url = https://github.com/Kotlin/kotlin-interactive-shell
+ arch = any
+ license = Apache
+ makedepends = maven
+ makedepends = awk
+ makedepends = kotlin>=1.4.32
+ depends = sh
+ depends = java-runtime>=8
+ provides = ki-shell
+ conflicts = ki-shell
+ source = kotlin-interactive-shell::git+https://github.com/Kotlin/kotlin-interactive-shell.git
+ sha256sums = SKIP
+
+pkgname = ki-shell-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2363ad96c2e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+kotlin-interactive-shell/
+pkg/
+src/
+*.tar.gz
+*.tar.xz
+*.tar.zst
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4695d226bf53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: kageru <kageru at encode dot moe>
+_pkgname=ki-shell
+_srcdir=kotlin-interactive-shell
+pkgname=ki-shell-git
+pkgver=0.3.3.r14.g0cc592d
+pkgrel=1
+pkgdesc="Kotlin Language Interactive Shell"
+arch=('any')
+url='https://github.com/Kotlin/kotlin-interactive-shell'
+license=('Apache')
+depends=('sh' 'java-runtime>=8')
+makedepends=('maven' 'awk' 'kotlin>=1.4.32')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_srcdir}::git+https://github.com/Kotlin/kotlin-interactive-shell.git")
+sha256sums=('SKIP')
+
+# Build against system Kotlin version because upstream is very slow to update
+_kotlin_version="$(kotlin -version | awk '{ split($3, a, "-"); print a[1] }')"
+
+build() {
+ cd "${_srcdir}"
+ echo "#!/bin/sh
+java -jar /usr/lib/${_pkgname}/${_pkgname}.jar" > ki
+ mvn -Dkotlin.version=${_kotlin_version} -DskipTests package
+}
+
+pkgver() {
+ cd "${_srcdir}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+package() {
+ cd "${_srcdir}"
+ install -Dm644 "lib/${_pkgname}.jar" -t "${pkgdir}/usr/lib/${_pkgname}"
+ install -Dm755 "ki" -t "${pkgdir}/usr/bin"
+}