summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2023-09-13 15:57:40 +0800
committertaotieren2023-09-13 15:57:40 +0800
commit5fc7f8e07a5676775cd249e53561477ae63447e6 (patch)
tree9f8d9026d1a295f015dcc9f19be3b649ae1709e5
parenta7bdde5e1f9414599a8faf7e905bbf596ec9fd29 (diff)
downloadaur-5fc7f8e07a5676775cd249e53561477ae63447e6.tar.gz
Update 1.6.3-4
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01a3fea24208..65c90857b6a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = kibot
pkgdesc = KiCad automation utility
pkgver = 1.6.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/INTI-CMNB/KiBot
arch = any
license = GPL-3.0
+ checkdepends = python-pytest
makedepends = python-setuptools
depends = blender
depends = ghostscript
diff --git a/PKGBUILD b/PKGBUILD
index 19307b7052d5..05b286a96e76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=kibot
pkgver=1.6.3
-pkgrel=3
+pkgrel=4
epoch=
pkgdesc="KiCad automation utility"
arch=('any')
@@ -41,7 +41,7 @@ depends=(
xorg-server-xvfb
)
makedepends=("python-setuptools")
-checkdepends=()
+checkdepends=(python-pytest)
optdepends=('kicad-interactivehtmlbom: Interactive HTML BOM generation plugin for KiCad'
'kicad-library: KiCad symbol, footprint and template libraries'
'kicad-library-3d: KiCad 3D model libraries')
@@ -62,7 +62,12 @@ build() {
python -m build --wheel --no-isolation
}
+# check() {
+# cd "${srcdir}/KiBot-${pkgver}"
+# pytest
+# }
+
package() {
cd "${srcdir}/KiBot-${pkgver}"
- python -m installer --destdir="${pkgdir}" dist/*.whl
+ python -m installer --no-compile --destdir="${pkgdir}" dist/*.whl
}