summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-03-17 13:50:42 +0000
committerGrey Christoforo2018-03-17 13:50:42 +0000
commit561b5273bff14bdc08e23998d1125e75c8ac1470 (patch)
tree69d055a3ad17bfb46e9d9bbf554d24fa041c39b4
downloadaur-561b5273bff14bdc08e23998d1125e75c8ac1470.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c8d709b24d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kicad-footprints
+ pkgdesc = Official KiCad footprint libraries -- stable release
+ pkgver = 5.0.0rc1
+ pkgrel = 1
+ url = https://kicad.github.io/footprints
+ arch = any
+ license = GPL
+ makedepends = cmake
+ provides = kicad-footprints
+ conflicts = kicad-footprints-git
+ source = https://github.com/KiCad/kicad-footprints/archive/5.0.0-rc1.tar.gz
+ md5sums = 5a624974a53e306b6debb08061cabf5b
+
+pkgname = kicad-footprints
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93f5d9f2777e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f831f5b9dd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=kicad-footprints
+_pkgver="5.0.0-rc1"
+pkgver=${_pkgver//-}
+pkgrel=1
+pkgdesc="Official KiCad footprint libraries -- stable release"
+arch=('any')
+url="https://kicad.github.io/footprints"
+license=('GPL')
+makedepends=('cmake')
+conflicts=('kicad-footprints-git')
+provides=($pkgname)
+source=("https://github.com/KiCad/kicad-footprints/archive/${_pkgver}.tar.gz")
+md5sums=('5a624974a53e306b6debb08061cabf5b')
+
+build() {
+ cd "$srcdir"
+ mkdir -p "$srcdir/build/"
+ cd "$srcdir/build"
+ cmake ../${pkgname}-${_pkgver} -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
+}