summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordx-mon2020-10-23 18:11:54 +0100
committerdx-mon2020-10-23 18:12:06 +0100
commit9e61e67804d5f9c28b322d920364414106185285 (patch)
treeb4a991b9bb5423c503cd72eadca8f9ef49cdce30
parent5bf337321008ec4b8e067e2bcccab6eabfdfe1c3 (diff)
downloadaur-9e61e67804d5f9c28b322d920364414106185285.tar.gz
Removed `updatePackage` as it now lives in the meta-repo
-rwxr-xr-xupdatePackage74
1 files changed, 0 insertions, 74 deletions
diff --git a/updatePackage b/updatePackage
deleted file mode 100755
index 44d9a6468a80..000000000000
--- a/updatePackage
+++ /dev/null
@@ -1,74 +0,0 @@
-#!/bin/bash
-
-_update()
-{
- cd kicad-symbols
- git fetch
- cd ../kicad-footprints
- git fetch
- cd ../kicad-packages3D
- git fetch
- cd ..
-}
-
-_symbolVersion()
-{
- cd kicad-symbols
- git describe --tag
- cd ..
-}
-
-_symbolHash()
-{
- cd kicad-symbols
- git rev-parse --short master
- cd ..
-}
-
-_footprintVersion()
-{
- cd kicad-footprints
- git describe --tag
- cd ..
-}
-
-_footprintHash()
-{
- cd kicad-footprints
- git rev-parse --short master
- cd ..
-}
-
-_package3dVersion()
-{
- cd kicad-packages3D
- git describe --tag
- cd ..
-}
-
-_package3dHash()
-{
- cd kicad-packages3D
- git rev-parse --short master
- cd ..
-}
-
-_buildPKGBUILD()
-{
- sed -e "s/@SYMBOL_HASH@/$(_symbolHash)/" \
- -e "s/@FOOTPRINT_HASH@/$(_footprintHash)/" \
- -e "s/@PACKAGE3D_HASH@/$(_package3dHash)/" \
- PKGBUILD.part > PKGBUILD
-}
-
-_updateSRCINFO()
-{
- makepkg --printsrcinfo > .SRCINFO
-}
-
-_update
-_buildPKGBUILD
-_updateSRCINFO
-
-git add PKGBUILD .SRCINFO
-git commit -m "Bump to KiCAD-Symbols $(_symbolVersion), KiCAD-Footprints $(_footprintVersion) and KiCAD-Packages3D $(_package3dVersion)"