summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2021-02-04 13:33:36 +0000
committerGreyson Christoforo2021-02-04 13:33:36 +0000
commit8cb71678f1592572b0dd18cf7d2145d8844abd44 (patch)
tree446e45d34d4af274167da03be5fde99705c90f37
downloadaur-8cb71678f1592572b0dd18cf7d2145d8844abd44.tar.gz
initial commit
-rw-r--r--.SRC1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD40
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRC b/.SRC
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/.SRC
@@ -0,0 +1 @@
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7cf6d1b080a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kicad-library-sparkfun-git
+ pkgdesc = SparkFun's KiCad Libraries
+ pkgver = V_0.5.r31.ge23396a
+ pkgrel = 1
+ url = https://github.com/sparkfun/SparkFun-KiCad-Libraries
+ arch = any
+ license = CC-BY-SA 4.0
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = git
+ provides = kicad-library-sparkfun
+ conflicts = kicad-library-sparkfun
+ options = !strip
+ source = git+https://github.com/sparkfun/SparkFun-KiCad-Libraries.git
+ sha256sums = SKIP
+
+pkgname = kicad-library-sparkfun-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ec5d2432dd4e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+SparkFun-KiCad-Libraries/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bb461d6ec0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=kicad-library-sparkfun-git
+pkgver=V_0.5.r31.ge23396a
+pkgrel=1
+pkgdesc="SparkFun's KiCad Libraries"
+arch=(any)
+url=https://github.com/sparkfun/SparkFun-KiCad-Libraries
+license=('CC-BY-SA 4.0')
+options=('!strip')
+makedepends=(
+cmake
+ninja
+git
+)
+conflicts=(kicad-library-sparkfun)
+provides=(kicad-library-sparkfun)
+source=(
+git+https://github.com/sparkfun/SparkFun-KiCad-Libraries.git
+)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd SparkFun-KiCad-Libraries
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd SparkFun-KiCad-Libraries
+
+ # footprints
+ install -m755 -d "${pkgdir}"/usr/share/kicad/modules
+ find . -name '*.pretty' -exec cp -r {} "${pkgdir}"/usr/share/kicad/modules \;
+
+ # schematic symbols
+ install -m755 -d "${pkgdir}"/usr/share/kicad/library
+ find . -name '*.lib' -exec cp -r {} "${pkgdir}"/usr/share/kicad/library \;
+ find . -name '*.dcm' -exec cp -r {} "${pkgdir}"/usr/share/kicad/library \;
+}
+