summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordx-mon2020-10-17 00:43:09 +0100
committerdx-mon2020-10-17 00:43:09 +0100
commit5588886db1a4a731bb2ac1d438dc582c3fba8eab (patch)
treef140565e65cf3e94dbe714541ea0082bfb4672ef
parenta56eb19f8c5a2080f5b9d808d36a1bc456b7df8f (diff)
downloadaur-5588886db1a4a731bb2ac1d438dc582c3fba8eab.tar.gz
Bump to KiCAD 5.99.0-4092-g1ee3df61c9
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD22
-rw-r--r--PKGBUILD.in16
-rwxr-xr-xupdatePackage9
5 files changed, 28 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f4443c344f1..57324c8706fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kicad-nightly
pkgdesc = Electronic schematic and printed circuit board (PCB) design tools
- pkgver = 5.99.0_4084_gb9f1601418
+ pkgver = 5.99.0_4092_g1ee3df61c9
pkgrel = 1
url = http://kicad-pcb.org/
arch = x86_64
@@ -20,10 +20,10 @@ pkgbase = kicad-nightly
depends = ngspice
depends = opencascade
depends = python-wxpython
- optdepends = kicad-library: for footprints and symbols
- optdepends = kicad-library-3d: for 3d models of components
- source = git+https://gitlab.com/kicad/code/kicad.git#commit=b9f1601418
- source = git+https://gitlab.com/kicad/code/kicad-i18n.git#commit=636831f
+ depends = kicad-library-nightly
+ optdepends = kicad-library-3d-nightly: for 3d models of components
+ source = git+https://gitlab.com/kicad/code/kicad.git#commit=1ee3df61c9
+ source = git+https://gitlab.com/kicad/code/kicad-i18n.git#commit=72653a3
source = kicad-nightly.env
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e22304e8eb80
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/kicad/
+/kicad-i18n/
diff --git a/PKGBUILD b/PKGBUILD
index 13d7cf3791c0..71ff3020cb00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Rachel Mant <dx-mon@users.sourceforge.net>
pkgname=kicad-nightly
-pkgver=5.99.0_4084_gb9f1601418
+pkgver=5.99.0_4092_g1ee3df61c9
pkgrel=1
pkgdesc='Electronic schematic and printed circuit board (PCB) design tools'
arch=('x86_64')
url='http://kicad-pcb.org/'
license=('GPL')
-depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
-makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig')
-optdepends=(
- 'kicad-library: for footprints and symbols'
- 'kicad-library-3d: for 3d models of components'
+depends=(
+ 'wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade'
+ 'python-wxpython' 'kicad-library-nightly'
)
+makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig')
+optdepends=('kicad-library-3d-nightly: for 3d models of components')
source=(
- 'git+https://gitlab.com/kicad/code/kicad.git'#commit=b9f1601418
- 'git+https://gitlab.com/kicad/code/kicad-i18n.git'#commit=636831f
+ 'git+https://gitlab.com/kicad/code/kicad.git'#commit=1ee3df61c9
+ 'git+https://gitlab.com/kicad/code/kicad-i18n.git'#commit=72653a3
'kicad-nightly.env'
)
sha256sums=(
@@ -23,12 +23,6 @@ sha256sums=(
'fce26af6b9c181a99197bfc9bc6c778561ad55a375480f4d0d73bb34078b5d18'
)
-pkgver()
-{
- cd "$srcdir/kicad"
- git describe --tags | sed -e 's/-/_/g'
-}
-
build()
{
cd "$srcdir/kicad"
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 5b4f39d6bff5..d786adc52613 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -7,12 +7,12 @@ pkgdesc='Electronic schematic and printed circuit board (PCB) design tools'
arch=('x86_64')
url='http://kicad-pcb.org/'
license=('GPL')
-depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
-makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig')
-optdepends=(
- 'kicad-library: for footprints and symbols'
- 'kicad-library-3d: for 3d models of components'
+depends=(
+ 'wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade'
+ 'python-wxpython' 'kicad-library-nightly'
)
+makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig')
+optdepends=('kicad-library-3d-nightly: for 3d models of components')
source=(
'git+https://gitlab.com/kicad/code/kicad.git'#commit=@KICAD_HASH@
'git+https://gitlab.com/kicad/code/kicad-i18n.git'#commit=@I18N_HASH@
@@ -23,12 +23,6 @@ sha256sums=(
'fce26af6b9c181a99197bfc9bc6c778561ad55a375480f4d0d73bb34078b5d18'
)
-pkgver()
-{
- cd "$srcdir/kicad"
- git describe --tags | sed -e 's/-/_/g'
-}
-
build()
{
cd "$srcdir/kicad"
diff --git a/updatePackage b/updatePackage
index 5abe619c8716..4e160ed52d68 100755
--- a/updatePackage
+++ b/updatePackage
@@ -37,10 +37,15 @@ _i18nHash()
_buildPKGBUILD()
{
- sed -e "s/@KICAD_VERSION@/$(_kicadVersion)/" \
+ kicadVersion=`_kicadVersion`
+
+ sed -e "s/@KICAD_VERSION@/$kicadVersion/" \
-e "s/@KICAD_HASH@/$(_kicadHash)/" \
-e "s/@I18N_HASH@/$(_i18nHash)/" \
PKGBUILD.in > PKGBUILD
+
+ sed -e "s/@KICAD_VERSION@/$kicadVersion/" \
+ kicad-library-nightly/PKGBUILD.in > kicad-library-nightly/PKGBUILD.part
}
_updateSRCINFO()
@@ -53,6 +58,8 @@ _buildPKGBUILD
_updateSRCINFO
version=`_kicadRawVersion`
+(cd kicad-library-nightly && ./updatePackage)
+
git add PKGBUILD .SRCINFO
git commit -m "Bump to KiCAD $version"
echo $version