summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Østergaard2014-07-09 07:25:19 +0200
committerNick Østergaard2014-07-09 07:25:19 +0200
commit7a086a84c8f90916fdc7c5a3df1821b9571faf21 (patch)
tree3d95c8fec4785f65620cbdcb431d509b2461e1aa
parent9aabd92bcd9a8253f6fc5dbdb05d4fecc09af248 (diff)
downloadaur-7a086a84c8f90916fdc7c5a3df1821b9571faf21.tar.gz
Remove wget dependency by using the source array
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71182ed51b2e..2cbc2ea50785 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = kicad-pretty-git
pkgdesc = KiCad .pretty repos. Theese are the new footprint library.
pkgver = 1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/KiCad
install = kicad.install
arch = any
license = GPL
makedepends = git
+ makedepends = curl
options = !strip
+ source = https://raw.githubusercontent.com/KiCad/kicad-library/master/template/fp-lib-table.for-pretty
+ md5sums = SKIP
pkgname = kicad-pretty-git
diff --git a/PKGBUILD b/PKGBUILD
index eab79265cb73..9b1f80ebd0d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Nick Østergaard <oe.nick at gmail dot com>
pkgname=kicad-pretty-git
pkgver=1
-pkgrel=2
+pkgrel=3
pkgdesc="KiCad .pretty repos. Theese are the new footprint library."
arch=('any')
url="https://github.com/KiCad"
license=('GPL')
-makedepends=('git')
+makedepends=('git' 'curl')
options=('!strip')
install='kicad.install'
+source=('https://raw.githubusercontent.com/KiCad/kicad-library/master/template/fp-lib-table.for-pretty')
+md5sums=('SKIP')
package() {
@@ -39,8 +41,7 @@ package() {
cp -r "$srcdir/$repo" "$pkgdir/usr/share/kicad/footprints"
done
- wget -q https://raw.githubusercontent.com/KiCad/kicad-library/master/template/fp-lib-table.for-pretty \
- -O "$pkgdir/usr/share/kicad/footprints/fp-lib-table"
+ mv $srcdir/fp-lib-table.for-pretty "$pkgdir/usr/share/kicad/footprints/fp-lib-table"
mkdir -p "$pkgdir/etc/profile.d"
echo "export KISYSMOD=/usr/share/kicad/footprints" > "$pkgdir/etc/profile.d/kicad-pretty-git.sh"