summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2015-08-21 02:34:14 -0500
committerNick Østergaard2015-08-27 18:53:41 +0200
commit9270ee0beec5bbba977ea75971dce2498b611c88 (patch)
tree3c09549239b7698c0f6fcf23e491690807cc8fd3
parentf9b8bdef4e817300d50e4d9261c89ea1c3ed8ba6 (diff)
downloadaur-9270ee0beec5bbba977ea75971dce2498b611c88.tar.gz
Increased maximum number of repositories from 100 to 200
Signed-off-by: Nick Østergaard <oe.nick@gmail.com>
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f918cdb0aeed..4ce1e0c6ce13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,8 @@
# intelligent, such that it will remove orphaned repos.
if [ -x /usr/bin/curl ]; then
- PRETTY_REPOS=(`curl -s https://api.github.com/orgs/KiCad/repos?per_page=2000 2> /dev/null \
+ PRETTY_REPOS=(`curl -s "https://api.github.com/orgs/KiCad/repos?per_page=100&page=1" \
+ "https://api.github.com/orgs/KiCad/repos?per_page=100&page=2" 2> /dev/null \
| grep full_name | grep pretty \
| sed -r 's:.+ "KiCad/(.+)",:\1:'`)
PRETTY_SRC=(${PRETTY_REPOS[@]/%/.git})