summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-14 17:09:17 +0000
committerGrey Christoforo2019-02-14 17:09:17 +0000
commit48f9c8db9066c19d4b3f91d2101b41f5a1f77dff (patch)
tree9d83e5d4196beb9ea8543b1fa381cc81fa54bbd3
parentf2390e0c7bc80f026d0fb957024dc41d8805fcd3 (diff)
downloadaur-48f9c8db9066c19d4b3f91d2101b41f5a1f77dff.tar.gz
use clang
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b1c38fffc4b..b38df439cd5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,11 +6,7 @@ pkgbase = kicad-rc
install = kicad.install
arch = any
license = GPL3
- makedepends = cmake
- makedepends = git
- makedepends = zlib
- makedepends = mesa
- makedepends = boost
+ makedepends = clang
depends = glew
depends = wxgtk
depends = desktop-file-utils
@@ -19,7 +15,7 @@ pkgbase = kicad-rc
depends = glm
depends = curl
depends = swig
- depends = wxpython
+ depends = python-wxpython
depends = opencascade
depends = ngspice>=27
depends = kicad-footprints
diff --git a/PKGBUILD b/PKGBUILD
index 6205746a157e..bd4eb5061107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,18 @@ pkgdesc="Official KiCad release candidates and dev snapshots"
arch=('any')
url="http://kicad-pcb.org/"
license=('GPL3')
-# glm 0.9.9.3 breaks the build
-depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl' 'swig' 'wxpython' 'opencascade' 'ngspice>=27' 'kicad-footprints' 'kicad-symbols' 'kicad-packages3d')
+depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl' 'swig' 'python-wxpython' 'opencascade' 'ngspice>=27' 'kicad-footprints' 'kicad-symbols' 'kicad-packages3d')
makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost')
optdepends=('kicad-symbols' 'kicad-packages3d' 'kicad-footprints' 'kicad-templates')
conflicts=('kicad' 'kicad-git' 'kicad-scripting-git' 'kicad-bzr')
provides=('kicad')
+makedepends=('clang')
_github_project='kicad-source-mirror'
source=("https://github.com/KiCad/${_github_project}/archive/${_pkgver}.tar.gz")
md5sums=('8ad977a2cde8d60c793ef4cb04086dc7')
install=kicad.install
+
#prepare() {
#sed -i -e 's|boost/uuid/sha1.hpp|boost/uuid/detail/sha1.hpp|g' kicad-source-mirror-5.0.0/3d-viewer/3d_cache/3d_cache.cpp
#}
@@ -27,7 +28,7 @@ build() {
cd "${srcdir}/${_github_project}-${_pkgver}"
mkdir -p build
cd build
- cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ CXX=clang++ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DKICAD_USE_OCE=OFF \
@@ -47,5 +48,5 @@ build() {
package() {
cd "${srcdir}/${_github_project}-${_pkgver}"
cd build
- make DESTDIR="${pkgdir}" install
+ CXX=clang++ make DESTDIR="${pkgdir}" install
}