summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-10-15 22:21:44 +0100
committerGrey Christoforo2018-10-15 22:21:44 +0100
commit61432d4964a9dc5fde9c89e3b204490dcbcc7fd4 (patch)
tree3cb8584c13daf78eec9268eee0e32a380a2871be
parent06f9e731695fce4852822074901fb09e9bdd642b (diff)
downloadaur-61432d4964a9dc5fde9c89e3b204490dcbcc7fd4.tar.gz
fix boost build
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7de602b31eb6..355b360f708b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,10 @@ source=("https://github.com/KiCad/${_github_project}/archive/${_pkgver}.tar.gz")
md5sums=('a0d5b122b82c05047744a011be7de0bd')
install=kicad.install
+prepare() {
+ sed -i -e 's|boost/uuid/sha1.hpp|boost/uuid/detail/sha1.hpp|g' kicad-source-mirror-5.0.0/3d-viewer/3d_cache/3d_cache.cpp
+}
+
build() {
cd "${srcdir}/${_github_project}-${_pkgver}"
mkdir -p build