summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Van Assche2018-01-15 14:55:30 +0100
committerFrederic Van Assche2018-01-15 14:55:30 +0100
commit48c99d294b8e8ffb4bfd821582f5d07e05e54ae1 (patch)
treeab169b5a5902c49f12c0cb3d04a37e30fdc8258a
downloadaur-48c99d294b8e8ffb4bfd821582f5d07e05e54ae1.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d95092b70e95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kicad-templates-git
+ pkgdesc = Official KiCad project templates
+ pkgver = ad2966f
+ pkgrel = 1
+ url = https://github.com/KiCad/kicad-templates
+ arch = any
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ conflicts = kicad-library-bzr
+ conflicts = kicad-library-git
+ conflicts = kicad-library-3d
+ conflicts = kicad-library
+ options = !strip
+ source = git://github.com/KiCad/kicad-templates.git
+ md5sums = SKIP
+
+pkgname = kicad-templates-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a17d0c260cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Frederic Van Assche <frederic@fredericva.com>
+
+pkgname=kicad-templates-git
+_pkgname=${pkgname%-*}
+pkgver=ad2966f
+pkgrel=1
+pkgdesc="Official KiCad project templates"
+arch=('any')
+url="https://github.com/KiCad/kicad-templates"
+license=('GPL')
+makedepends=('cmake' 'git')
+options=('!strip')
+conflicts=('kicad-library-bzr' 'kicad-library-git' 'kicad-library-3d' 'kicad-library')
+source=("git://github.com/KiCad/kicad-templates.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-parse --short HEAD # Fix to better comply with github display
+}
+
+build() {
+ cd "$srcdir"
+ mkdir -p "$srcdir/build/"
+ cd "$srcdir/build"
+ cmake ../${_pkgname} -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
+ rm ${pkgdir}/usr/share/kicad/template/*.kicad_wks
+ rm ${pkgdir}/usr/share/kicad/template/kicad.pro
+}